Support » Fixing WordPress » WP 5.0.1 ‘publishing failed’

  • Resolved iaeon

    (@iaeon)


    I cannot get WP 5.0.1 to edit or create posts or pages when Gutenberg is active.

    VPS – Ubuntu 14.04.5 LTS – PHP 7.13 (others tried) – NGINX (Apache tried) – Plesk Onyx Version 17.8.11 Update #34

    I tried adding the following to php.ini and restarting php / Apache / NGINX
    always_populate_raw_post_data = -1

    I have tried disabling ALL plugins and using a standard WordPress theme.

    Nothing works!

    Ideas?

    (I have tried a second VPS with the same results.)

Viewing 7 replies - 16 through 22 (of 22 total)
  • I had the same issue but mine turned out to be the following;

    WordPress Address (URL)
    Site Address (URL)

    Did not match, one had the www and the other did not. Once I changed them both to be the same my site was working again, I’m able to publish and update.

    Steve Henning

    (@consignmentsoftware)

    Adding this to htaccess resolved the issue:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /software/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /software/index.php [L]
    </IfModule>

    Best Consignment Shop Software

    sujaljain007

    (@sujaljain007)

    I got it solved now. The reason being that was the ssl certificate configuration!
    Installed Really Simple SSL and got the problem solved!

    seems everyone has a different solution, as long as something worked for them. I did find my solution here:

    I am using a synology box and ngix as the default web server. On one box wordpress works, on the other it doesn’t. Didn’t quite get why, but switching both to apache did solve the issue for one.

    The other was more stubborn. The wordpress site WORKED, it was visible, but I couldn’t add any posts.

    It was reading the post regarding permalinks that reminded me, there was(/is?) an issue that until you change the permalinks, the .htaccess file hasn’t been updated/written. Once I updateds the permalink and change it from day/date to something else and saved it, and then changed it back, it worked for me!

    the reason is permalinks which take you 404 error for posts.

    just go to settings >> permalinks and hit “save changes” button.

    it solves “publishing failed”

    A WP Life

    (@awordpresslife)

    But, guys! Activating classic editor isn’t a solution I think.

    A WP Life

    (@awordpresslife)

    Really Simple SSL is the solution if you are using Cloudflare SSL on site.

Viewing 7 replies - 16 through 22 (of 22 total)
  • You must be logged in to reply to this topic.