Support » Plugin: WP Job Manager » WP 5.0.1 meta-box incompatibility

  • Resolved alzaran

    (@ajoyce2016)


    Edited jobs no longer show their metadata under Location/Company name/Company website, etc. That metadata is there and filled out (that is, it shows up on the frontend), but in the backend editor the fields are blank. If I type in information, that information saves but then displays blank again when the page is refreshed.

    This problem began with WordPress 5.0 — we are using the Classic Editor plugin, but perhaps this is an incompatibility with WP Job Manager?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Contributor Jen H.

    (@jenhooks)

    Hey @ajoyce2016,

    Could you please post your site URL here, so I can take a look?

    If you’d rather not share your URL publicly, you can reach us via this contact form:

    https://wpjobmanager.com/support/

    Please reference this thread in your email.

    If you have a WP Job Manager addon, please make sure to email us from the address you used when you purchased your license.

    Cheers.

    Sure thing, it’s mbts.edu/jobs — we are having problems on the backend, however, do you require access to that?

    Plugin Contributor Jen H.

    (@jenhooks)

    Hi @ajoyce2016,

    No, we don’t have access to your dashboard. I wasn’t really able to determine anything from the frontend of your site. Have you since updated to WordPress 5.0.3?

    Let’s go back to this:

    If I type in information, that information saves but then displays blank again when the page is refreshed.

    Are there any JavaScript errors in your browser’s console after you do this? You can find guidance for checking this here, if you need it:

    https://en.support.wordpress.com/browser-issues/advanced-browser-troubleshooting/#javascript-errors

    Let us know if you see anything there.

    alzaran

    (@ajoyce2016)

    Yes, we are on WP 5.0.3.

    There’s nothing that looks specific to WP Job Manager in the console — here’s a screencap.

    The main problem is, the job data definitely exists, but it’s not being shown in the edit fields (only on the frontend). But when we put info into those edit fields, it supersedes the previous info (as it should)

    https://imgur.com/a/MOAECXw

    These same errors show both before and after I save a listing, so I don’t think they’re connected. . . seems to be something in how WP is pulling the data from the DB? Possibly an issue with classic editor plugin, which we’ve been using since WP 5

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi!

    This is a very odd problem. I’ll ask our developers if they have any insight about it, and I’ll get back to you!

    Plugin Contributor Richard Archambault

    (@richardmtl)

    Hi! We don’t know what would be causing this, and we can’t reproduce. Can you try disabling everything except for WPJM and the Classic Editor? You can do this with the Health Check plugin: https://wordpress.org/plugins/health-check/

    alzaran

    (@ajoyce2016)

    Hi Richard,
    I was not able to reproduce the problem with the WP troubleshooter — however, I think the issue was tied to the Classic Editor or the Gutenberg Ramp plugins. I have set the Job Manager to use the Gutenberg editor, and the fields are displaying perfectly now.

    For what it’s worth, the health check plugin showed no issues with Job Manager + either of the above plugins, so it’s likely it was another conflict and moving to the Gutenberg editor helped things out.

    Thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘WP 5.0.1 meta-box incompatibility’ is closed to new replies.