Support » Plugin: TablePress » WP 4.4 issue, virus or plug-in incompatibility?

  • Resolved shanimal

    (@shanimal)


    I posted this in a more general forum and in the WP Google Maps plugin forum, but someone suggested I try here as well.

    I recently updated to WP 4.4, and all plugins are updated. Around the same time, installed Wordfence plugin. Shortly after this, logged in to make some changes in a few plugins, but I rarely change them so I don’t know if I’ve had the following issues for awhile and they’re just now appearing, or if recent changes sparked them.

    First noticed issues in WP Google Maps plugin. Added a location, went in to one of my existing maps, tried to add the new location to that map, and the map disappeared altogether. Another map then made a duplicate of itself. Opening any existing map either makes one disappear and/or makes others duplicate themselves. None of the deleted or duplicated maps show up on my website.

    Then noticed in my plugins page on the dashboard that a few plugins had deactivated. I went to reactivate them, and others would deactivate.

    Someone on one of the other forums suggested I download WP 4.4, delete my files and manually replace them with the download. This is WAAAAY above my skill level, so instead I tried deactivating all plugins, reinstalling WP 4.4 and reactivating all plugins. At first this seemed to help with the WP Google Maps plugin, but then I went into my Tablepress plugin and the same thing is happening – tables are deleting and duplicating themselves.

    I tried deactivating and deleting Wordfence, this solved nothing, so I reinstalled it. I also went in and tried to delete as many plugins as possible (some I knew weren’t being used, but others I’m not positive so am leaving them alone.)

    Can WP get a virus? I had WP SpamShield installed but deleted it just in case as it may have also been recently added (I can’t remember for sure.)

    I’m pretty much MEGA beginner level – I don’t understand a lot of the terminology, coding, etc. so am clueless what else to try. Any ideas would be very much appreciated!!

    https://wordpress.org/plugins/tablepress/

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter shanimal

    (@shanimal)

    Wasn’t sure how to access my server as you mention above so asked my IT guy and mentioned all the weirdness that’s been happening. He had a suspicion that this wouldn’t solve it and logged into my WP from his office. He tried deactivating all plugins, then reactivating a few at a time and testing the problematic plugins to see if the problem would reappear. I was also logged in from my office, and could recreate the problem here but he wasn’t able to there. He brought his laptop to my office and same thing – his seemed stable, my system would recreate the problem. After a couple minutes he recognized the behavior and got me all fixed (I was using Firefox, he had me install Chrome and it worked fine there, so from now on I’ll only use Chrome to access WP!) Here’s his explanation in case others are having similar issues:

    Some browsers (or plugins) try to “pre-load” some links. In the case of browsers, they do it to try to speed up page load time for links that you might be about to click on. They can fetch the link in the background, then when you click on it, they’ve already got the page data ready to go. But, browsers are usually smart enough not to do this in things like WordPress admin areas. There’s a Wikipedia article about it here: https://en.wikipedia.org/wiki/Link_prefetching

    Your culprit plugin or extension — and I’m going to guess it’s the shopping one, [I use Goodserach.com for all my searches – never use the Goodshop portion of it though] it’s the most suspicious one by far — is probably doing it to do something like try to set up referral links, so that when you click on a link to buy something somebody else gets a little kickback for it, or to collect data on your shopping and browsing habits. Those are the two most common business models for those things.

    So what’s happening is when you’re in the admin area, SOME of the “Copy” and “Delete” links are being clicked by this plugin.

    We know it’s not Firefox itself because everything was OK when Firefox was launched in Safe Mode (all plugins disabled).

    Plugin Author TobiasBg

    (@tobiasbg)

    Hi,

    thanks for your post, and sorry for the trouble.
    Also, sorry for the long wait for a reply. As a I was on a long vacation without internet access the last couple weeks, I could not reply earlier.

    Wow, that’s a really weird issue! Thanks a lot for the update and the details on this! I really hope that I never see this issue again 🙂

    Best wishes,
    Tobias

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘WP 4.4 issue, virus or plug-in incompatibility?’ is closed to new replies.