Support » Plugin: Active Directory Integration » WP 4.0 – ERROR: Please enter your password.

  • Hi, we’re using Version 1.1.5. We recently upgraded to WP 4.0 and since then have been unable to add a new user. When we try to add a user, we get the following error message:
    “ERROR: Please enter your password.”

    If we disable AD Integration, we’re able to add a new user.

    We also upgraded from php 5.3 to php 5.4 at the same time that we upgraded to WP 4.0.

    Thanks for your help!

    https://wordpress.org/plugins/active-directory-integration/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Thread Starter brasselleg

    (@brasselleg)

    It looks like the problem may be a conflict with php 5.4 — when I rolled back to php 5.3.14 on my local dev environment, the error disappeared. Is anyone else having a similar problem? Any suggestions would be greatly appreciated.

    Justin

    (@justinxhale)

    Im having the EXACT same problem right now… i dont what to do to fix it!

    I too, am having this exact issue. Any idea on solving it? Specs:

    Windows Server 2008 R2
    WordPress 4.0
    PHP 5.4.24
    Active Directory Integration 1.1.5

    Can you turn on debugging in your config and post the log information?

    I’m running 5.4.26 and no issues.

    Jw

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);

    Windows Server 2008 R2 Enterprise Edition Service Pack 1
    Wordpress 4.1
    PHP 5.4.26
    Active Directory Integration 1.1.5

    ^ Those are my logs you requested. Sorry for the delay. But they didn’t really reveal anything out of the ordinary to me.

    Please use a pastebin for long error logs –
    http://codex.wordpress.org/Forum_Welcome#Posting_Code

    Sorry about that, here is my log:

    http://pastebin.com/gVjp0Jn0

    Just to be clear, the error I am receiving once trying to sign in is the following:

    You do not have sufficient permissions to access this page.

    SOLUTION:

    I resolved the issue. Change the BASE DN to the following:

    Let’s say your Domain is: support.google.com, you would use the following:

    DC=support,DC=google,DC=com

    I didn’t need the OU in front of it at all.

    Hope that helps others.

    JChambo, I entered in the information on the “Base DN” setting as you suggested but I am still experiencing the same problem. I also noticed the issue after we upgraded to PHP 5.4.

    I hsould mention however that I have two websites with multi-site turned on and they are not having any problems at all, it is just the single website with multi-site turned off.

    Thanks.

    SARguy

    (@sarguy)

    brasselleg did you ever find a solution to this problem outside of switching back to the older version of PHP?

    Thread Starter brasselleg

    (@brasselleg)

    No, we never found a solution, just a work around… We’re entering a default password for new users, but not telling them about it and telling them to use their AD password instead.

    SARguy

    (@sarguy)

    I’ve had to resort to do the same thing, however, I do not like the fact that these accounts could potentially log in with their AD password or the random password that is created for them.

    Thanks!

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘WP 4.0 – ERROR: Please enter your password.’ is closed to new replies.