Support » Plugin: WOW Slider » WP 4.7.3 Database Problem – wowslider/list-table.php on line 239

  • anja12345

    (@anja12345)


    I’ve the newest version WordPress 4.7.3 and you plugin makes this mistake in the database and it’s showen at the top of the Dashboard:

    Strict Standards: Declaration of WOWSlider_List_Table::single_row() should be compatible with WP_List_Table::single_row($item) in /var/www/vhosts/lovestorm-people.com/httpdocs/develop_webseite/website/wp-content/plugins/wowslider/list-table.php on line 239

    Please can you help me how to delete this mistake. Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • dcomment

    (@dcomment)

    I’ve approximatively the same problem. The alert on WP is:

    Warning: Declaration of WOWSlider_List_Table::single_row($id, $data, $index) should be compatible with WP_List_Table::single_row($item) in /volume2/web/mybees/wp-content/plugins/wowslider/list-table.php on line 0

    brandinwebdesign

    (@brandinwebdesign)

    same problem her i hope for a fix

    Me too have this problem, how to fix it????

    If you set WP_DEBUG to ‘false’ in wp-config.php file. These do not affect your website.

    Bot the problem is that above does not work sometime.
    That can happen on cheap/shared hostings that force displaying PHP ERRORS, warnings and notices.
    In that case, you can remove this line from your wp-config.php file:

    define('WP_DEBUG', false);

    and place this:

    ini_set('log_errors','On');
    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    in my case its working.

    We changed it on this way. It works 🙂

    \wp-admin\includes\class-wp-list-table.php Zeile 1240

    public function single_row( $item ) {

    –>

    public function single_row( $item, $level = 0, $data = array(), $index = 0 ) {

    ———————————-

    \wp-content\themes\kleo\kleo-framework\lib\class-tgm-plugin-activation.php Zeile 2536

    public function single_row( $item ) {

    –>

    public function single_row( $item, $level = 0, $data = array(), $index = 0 ) {

    ———————————-

    \wp-admin\includes\class-wp-posts-list-table.php Zeile 1161

    public function single_row( $post, $level = 0 ) {

    –>

    public function single_row( $post, $level = 0, $data = array(), $index = 0 ) {

    ———————————–

    \wp-content\plugins\wowslider\list-table.php Zeile 174, 169

    function display_rows(){
    $index = 1;
    foreach ($this -> items as $data){
    $this -> single_row($data[‘id’], $data, $index);
    $index++;
    }
    }

    function single_row($id, $data, $index){

    –>

    function display_rows(){
    $index = 1;
    foreach ($this -> items as $data){
    $this -> single_row($data[‘id’], 0, $data, $index);
    $index++;
    }
    }

    function single_row($id, $level = 0, $data = array(), $index = 0){

    I tried the later proposition and it didn’t work.

    But I’ve to say, it’s quite complicated and it’s possible I made one or more mistake by copying. Than I had to copy back my saved files (don’t forget to do it before trying this solution).

    Does someone else made a better experience than mine?

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP 4.7.3 Database Problem – wowslider/list-table.php on line 239’ is closed to new replies.