Support » Localhost Installs » WP 3.9, AWS Micro Instance cant access Themes, Plugins & Updates

  • Hello,

    I am new to this forum and wordpress so I apologize if I am already breaking any rules.

    I have an issue with WP 3.9 and AWS t1.micro instance LAMP server running MySQL 5.5.36. Completely fresh/clean install. I just created the instance today and installed WP today. There are no additional themes and plugins on this installation. I followed the AWS LAMP server and WP install instructions word for word. (perhaps that was the issue?)

    I am unable to access: Themes, Plugins and Updates,

    Basically I get an error page in chrome:

    Error code: ERR_EMPTY_RESPONSE

    In Firefox:

    The connection was reset

    I tried the recommended renaming of the themes and plugins dirs. This works and I am then able to access the pages. However of course I would rather like to be able to have themes and plugins so when I add the directories back in I get the same error.(permissions appear OK?)

    Please note. I have another AWS t1micro instance running WP 3.8.3 with MySQL 5.5.34. I have not had any issues there……

    Does anyone have any suggestions. Should I downgrade MySQL?

    Thank you.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Casey Driscoll


    Hi jeffsun22,

    I haven’t personally run into this before, and from my quick research online I couldn’t find anything conclusive (however it looks like many have faced a similar issue).

    I think your install is probably just fine, I don’t think downgrading anything with help.

    Since you are able to access it by renaming the directories, my gut says it is a memory issue. Can you raise (maybe double?) the memory in your php.ini and report back?


    Thank you for your response. I will try to do this as soon as possible. Please note, I realize these micro instances are not real ‘performers’ So I had it setup with a 1GB swapfile. I was previously running a drupal site on a micro instance and I tried upping the memory limit to no avail (drupal kept crashing so eventually I upgraded to a small instance). However having said all this my other WP site (v3.8.3) is running on an almost identical setup (t1micro with 1GB swap) and it has some fancier plugins and themes installed – its slow but its working….. unlike 3.9…

    Never the less, I will try this and report back.

    Thank you.

    Hey Jeffsun22

    I was on the same boat. Upgraded instance to mini and am now able to access.


    Ok…. So I am not sure what I did to fix this. But here it is:

    1. Manually Dropped the DB
    2. Deleted the 3.9 WP files in /var/www/html
    3. Put in the 3.9 WP files back in /var/www/html
    4. Made the DB again.
    5. Put back in the old wp-config.php and .htacess
    6. Reset all permissions

    Now it works…. Its still a micro instance…. I dont get it… I guess you can close out this topic….

    Ok wanted to add one more thing. The only thing that I could think of that made this work is the following:

    1. Before my post I made the swap file
    2. After my post I shutdown the instance and gave up
    3. After your responses I restarted the instance

    Now I am thinking that it COULD be a memory issue and stupid me forgot to reboot the instance and get the swap to run….. Lesson learned.

    I take all that back Swap is not enabled…. BTW max mem limit in PHP.ini is 128MB so it works I just dont know why.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP 3.9, AWS Micro Instance cant access Themes, Plugins & Updates’ is closed to new replies.