Support » Plugin: Debug Objects » WP 3.8 : Plugin installed and activated : No controls

  • Resolved deas0815


    Hallo everybody,

    I installed and activated latest debug objects on a completely fresh and virgin WP 3.8. I am logged in as a user with admin privileges, but the menu entry “debug objects” does not appear. Tried the same thing on 3.7.1 and it appears as expected. Tried the path /wp-admin/tools.php?page=debug-objects/inc/autoload/class-settings.php on 3.8 and get a message telling my “Du hast nicht die erforderlichen Rechte, um auf diese Seite zuzugreifen”, so it seems a privileges problem.

    Does anyone have a fix for that ?


Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Frank Bueltge


    If is a single install, not multisite, then is the options in menu item “Tools”. Alternativly, can you test with the version from GitHub – I have tested now on a fresh single install and it works fine.

    Thanks for the fast response. The version from github fixed it for me on WP 3.8.

    Just to be clear: I tested fresh, virgin installs of wordpress – 3.7.1 and 3.8 with the current debug-objects release 2.1.16. It was the sole extension (plugin/theme). 3.7.1 worked fine, 3.8 had the permission problem.

    Thanks again, Frank !

    Marking as solved.

    Plugin Author Frank Bueltge


    Hm, but the permission topic was not change. But thanks for the hint, good hint for me to release a new version her on

    Seems I messed up somehow. It 2.1.16 now works on a fresh 3.8 install, but:

    The reason I got into this was that I had two other “non virgin” systems both exhibiting the privileges problem with debug objects. Seems there is some sort of a general permission issue

    Anyways, I have now fixed the problem on the other two systems. Removing and reinstalling the plugin did the trick. Just deactivating/activating was not enough. I tried a few times.

    Plugin Author Frank Bueltge


    Hmm. On the activation of the plugin was add the new capability to the Admin role

    $GLOBALS['wp_roles']->add_cap( 'administrator', '_debug_objects' );

    I think it is enough, that you deactivate, activate.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘WP 3.8 : Plugin installed and activated : No controls’ is closed to new replies.