WordPress.org

Support

Support » Miscellaneous » WP 3.6 – Live Writer no longer connects

WP 3.6 – Live Writer no longer connects

  • After updating to 3.6 I can no longer get Live Writer to connect to my personal wordpress.com blog. When attempting to open a saved draft I’m getting this error in Live Writer:

    The server reported an error with the following web address:

    http://site.domain.com/xmlrpc.php

    503 Service Temporarily Unavailable

    I’ve read number of posts which say to re-enable External Publishing but the settings they point to does not appear in my dashboard at all. It’s unclear if something has changed in 3.6 as this has worked fine for years prior.

Viewing 15 replies - 1 through 15 (of 28 total)
  • Probably same problem here, getting the 503 error when trying to refresh or upload to my blog using MarsEdit. Interestingly enough, when I try to upload an entry with several photos, the first one is uploaded just fine and then I get the 503.

    I run my 3.6 on a 1&1 server. Tried reinstalling 3.6, disabling all plugins, adding mod_security exceptions to the .htaccess, nothing helped so far.

    Haven’t found a solution yet, but I’m thinking that it might be a problem with 1&1 settings, in recent years this problem seems to have been solvable by disabling mod_security via the .htaccess file, but that doesn’t work for me.

    Help would be appreciated.

    I’ve opened a support case with 1and1 and will update this thread if they can figure out what is causing the problem.

    I really think this is related to the size or length of the request as I’ve randomly gotten this error in the past when attempting to post drafts or publish articles and I typically just have to try 3 or 4 times before it finally works.

    This error now though is 100% consistent and I can never load a saved draft from the site.

    I have exactly the same problem, and I’m also hosting on 1&1.

    For me too, unfortunaly ifttt.com is disconnected and the iOS-App doesnt work too.

    I opened a support case too.

    I’m ready to leave 1and1; their support is simply atrocious. Wasted 30 minutes on the phone yesterday with a clueless support engineer who was of zero help.

    I’ve tried a few other things with no luck. I added the following code to the .htaccess file on the root of my wordpress folder:

    <Files xmlrpc.php>SecFilterInheritance Off</Files>​​​

    But this actually broke it completely, triggering a 500 server error for every attempt. So I reverted and I’m back to the 503 errors.

    What makes me think this is related to request size is that when I use the ‘Open Recent Post’ option in WLW and then select my blog, the request to parse the list of articles on my servers works almost exactly 50% of the time. Performing the same requests, but asking for different sizes of article lists (20, 50, 100, etc) will intermittently succeed or fail, and the request size doesn’t matter. Sometimes 20 will work and 50 will fail, other times 20 will fail, yet 100 will work. So I’m convinced this is not some type of ‘something was switched off’ problem.

    I also am able to create a new article in WLW and then both post a draft and publish the article. When doing these steps the 503 will happen sometimes, but as long as I keep hitting post it will eventually succeed (typically after 3/4 attempts). But downloading a saved draft from the site into WLW still fails 100% of the time.

    Can I assume you guys are also seeing this as of WP 3.6? This worked fine in 3.5.2 and earlier.

    Yes, it’s definitely a 3.6 issue for me too. I’m not using Windows Live Writer, but every client that I’ve tried comes back with the same error.

    I think given that we’re all on 1&1 it’s something in the way that 1&1 servers are configured. I’m clueless as to what it could be though – it’s probably something that changed in xmlrpc.php in 3.6.

    Investigating further, using Marsedit, if I’ve created a post using the web and hit the refresh button, it pulls down the new post – but it then gives me the error. I can edit existing posts and send changes fine. I can create a post and send it, and it’s posted OK. It seems like it’s only when the client asks for a listing of posts that it gets the error, and the error appears only after it’s pulled down the list.

    Bizarre.

    I downloaded a trial version of BlogJet and was able to parse the list error-free as well as download a saved draft, from the same workstations where I also have had WLW installed. So not all off-line editors appear to be impacted, albeit the most popular ones unfortunately.

    For me the 503 errors appear with wordpress for iOS, when I try to authenticate. BTW when i call the /xmlrpc.php with Safari at iOS directly, it respones the “XML-RPC server accepts POST requests only.” – message.

    That message is normal when simply accing the xmlrpc.php page from a browser. I’ve checked another site running 3.5 and the same response is shown.

    Support keeps telling me to ‘try the content of this article’
    http://phpxmlrpc.sourceforge.net

    Oh my lord; 1and1’s ‘higher level’ tech support just responded that “the error is due to [my] CPU limit” and then they directed me to the ‘Updating WordPress’ page.

    I can see this is going nowhere.

    Meanwhile i can assume that it is not an 3.6 issue. I switched back to 3.5 and same behavior there.

    I’m having the same problem with MarsEdit. It started a few days ago. First, there were problems uploading images with posts, then problems across the board. Sometimes, if I try a half-dozen times, I can get a post to upload. But every time I refresh MarsEdit, I get the error.

    I do recall getting blocked by 1and1 a couple of years ago, because I had set the number of posts MarsEdit grabs too high. Weird, because if I had a lot of hits on my site, that would probably generate the same problem.

    If anyone finds a solution – other than changing hosts, something I’ve been planning to do for a while – please post it.

    I wonder if the baseline memory usage for WordPress has inched up a tiny bit with this 3.6 release, and that is causing the variety of issues with 1&1. This is a pattern that I’ve seen with other hosts have seen in the past. Basically if the baseline WordPress memory usage is e.g. 31MB and 1&1’s PHP memory use limit was 32MB, little differences to some WordPress actions can suddenly make it jump over that 32MB limit and crash on the server.

    If anybody experiencing the problem with 1&1 is able to get them to increase the memory allocation for their PHP configuration, as a test, it might be interesting to learn whether that addresses the issues.

    No it doesn’t. My server is configured with 128M.
    I played around with some other php.ini-settings and it doesn’t solve the problem.

    I am having this same problem, I cannot find a solution. I have emailed 1&1 support details of this.

    I have helped someone use windows live writer to post on a wordpress.com hosted wordpress site and it is still working fine. So this suggests it is a 1&1 problem.

Viewing 15 replies - 1 through 15 (of 28 total)
  • The topic ‘WP 3.6 – Live Writer no longer connects’ is closed to new replies.