WordPress.org

Support

Support » Plugins and Hacks » [Resolved] wp 3.6 insert link

[Resolved] wp 3.6 insert link

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    Both the default WordPress insert link dialog and the TinyMCE advanced link dialog work properly here in Firefox, Chrome and IE 10-9-8-7. Do you see any JS errors?

    No, i can only link if i highlight the text and press with the second mouse button, this only started when i upgraded to 3.6
    http://img51.imageshack.us/img51/5528/tfor.jpg

    i tested with another browser, it is a firefox problem, in chrome is working

    Hello,

    I’m facing the same issue: I’m not able to add a link to a text anymore.
    When I highlight some text, the link icon (chain) remains grey.
    Same after uninstalling / installing again TinyMCE advanced 3.5.8.

    Installed WP: 3.6
    Browser: Firefox portable 22.0
    Issue not present in IE8 but with a strange behaviour: first highlight of text doesn’t work (grey icon). Ok after a second attempt.

    Please help !
    Thank you

    Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    Hmm, no, still can’t reproduce it here.

    – Could that be a caching problem? Please delete cache, quit the browser, start it, and try again.
    – Does the link icon work despite that it’s greyed out?
    – Does it work in the standard Visual editor, if you disable TinyMCE Advanced and clear the browser cache?

    Thanks.

    Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    Another suggestion: try enabling (or disabling) the “Advanced Link” checkbox temporarily, then clear browser cache and see if any change.

    Thank you Andrew for your support.

    – Could that be a caching problem? Please delete cache, quit the browser, start it, and try again. Same issue
    – Does the link icon work despite that it’s greyed out? No
    – Does it work in the standard Visual editor, if you disable TinyMCE Advanced and clear the browser cache? Link icon remains grey also in standard visual editor.
    Does it mean that the issue comes with WP 3.6 and not because of TinyMCE Advanced ?

    Another suggestion: try enabling (or disabling) the “Advanced Link” checkbox temporarily, then clear browser cache and see if any change. No change

    Could it be useful if I grant you a temporary admin account ?

    Andrew.

    First Kudos to you and your plugin! I have it installed a few of my sites and am not having an issue except on one of them. This is a site I inherited with a few plugins so I am sure it is a conflict of some sort.

    That being said, if I click in the text editor, or highlight my text and then press ALT, SHIFT, and A at the same time (your shortcut) the Link is no longer grayed out and also works as normal.

    Tried your suggest above but to no avail, but there is a workaround to have it function.

    Used IE9 and it worked up until the update to 3.6, but again just for one site that has a few plugins.

    when i upgraded to 3.6 i also update NextGEN Gallery, maybe it’s related

    BushidoPT, same here. I rolled back NextGEN to make sure that was the issue. You can follow the steps here: http://www.nextgen-gallery.com/how-to-rollback-a-version/ and that was indeed the issue. Make sure you follow what they have in place and you will be good to go.

    Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    @fredmccr yes, it seems it’s a problem with the default TinyMCE in WordPress, not caused by the plugin. The next step is to look for JS errors in the browser console. Open the console, reload the page and try again. Then post any JS error here plz.

    @spotlightweb thanks 🙂 Could you try different browser, perhaps Chrome, and look for errors in the console too. If the keyboard shortcut is working, the error is probably coming from not fully loaded JS file, etc.

    @bushidopt think this still may be a caching problem in Firefox. Haven’t heard of any incompatibilities with NextGEN. Maybe try clearing the cache and restarting FF 2-3 times.

    Plugin Author Andrew Ozz

    @azaozz

    WordPress Dev

    Ah, we posted almost at the same time with @spotlightweb 🙂

    Disregard my previous comment re: NextGEN. Hope this will be fixed soon.

    Thanks for the quick responses Andrew. There 2.0 release just came out at the end of July (30th or 31st) so hopefully they resolve in the next patch.

    Once again, great plugin and thank you for your time.

    tks all for your time lets wait for the NextGEN patch.

    I do confirm that NextGen Gallery 2.0 came in conflict with TinyMCE.
    I rolled back NGG to previous version 1.9.13, I can now insert a link to a text. Issue fixed, thank you all for your support !

    NB: NGG release 2.0 seems to be a real crap, have a look at their support page !

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] wp 3.6 insert link’ is closed to new replies.