WordPress.org

Support

Support » How-To and Troubleshooting » WP 3.5 Visual Editor Broken, Can't Insert Media, No Editing Tools

WP 3.5 Visual Editor Broken, Can't Insert Media, No Editing Tools

  • Hello,

    I’ve just upgraded to WP 3.5 from 3.4.2 and have the following issues:
    -When editing a post, the visual tab doesn’t go anywhere, it’s there, I can click it, but it doesn’t load any changes.

    -I can click “Add Media”, it’ll pop the media manager (which is a beautiful improvement), I can upload a file, it’ll show up correctly, but when I click “Insert Into Post” nothing happens, but it returns me to the line in the post where I was editing, but no code.

    -If I click “Media” and enter the media manager, and then click “View”, it’ll launch a page (http://www.sector67.org/blog/?attachment_id=1924 for instance), but the image won’t be there. If I copy target URL and paste it into the browser it’ll show up (http://www.sector67.org/blog/wp-content/uploads/2012/12/laser-cut-house-1-4-width-1024×662.png)

    -There’s no tool box at the top of the edit post area. Usually there’s a variety of tools (at least there was previously), was this lost in the new version or is this also broken from my installation?

    Troubleshooting steps I’ve taken:
    -Disable *all* plugins, didn’t show any improvement so I re-enabled them.
    -Install and test Twenty Eleven or Twenty Twelve, also disabled plugins, no improvements.

    Any other ideas? My next step was going to be manually copying over all of the files for the installation to see if something was mangled on the installation the first time.

Viewing 15 replies - 1 through 15 (of 18 total)
  • Please try the following standard troubleshooting steps:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Eleven theme to rule out any theme-specific problems.

    – resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress. Make sure that you delete the old copies of files & folder before uploading the new ones.

    I’m experiencing this same problem. I tried this same thing on a Mac in Google Chrome and Safari. The server runs NGINX and Varnish. How about your setup? Is this problem NGINX specific?

    Same problem here. Running Nginx with varnish.

    Moderator kmessinger

    @kmessinger

    @obsessedwithfilm
    @eilijon

    Please start your own topics. WP has no problems running Nginx with varnish.

    Why on earth do I need to start my own topic? The original poster has said exactly the same problems that we are experiencing? Surely copying and pasting exactly the same information is just duplicating content/effort?

    <deleted>

    esmi

    @esmi

    Forum Moderator

    No. We actually track issue via topics, so posting to an existing topic skews our results,. It also causes untold problems for the forum volunteers who are trying to help

    Moderator kmessinger

    @kmessinger

    Unless you’re having 100% without any doubts or variation, the exact same problem, do not post in someone else’s thread. Start your own topic.
    -http://codex.wordpress.org/Forum_Welcome#Where_To_Post

    It just makes it easier to keep track of for the mods and devs and it makes the chance of you getting help more probable.

    Having the same problem. It’s not plugins – it’s a new site, so there aren’t any activated to begin with . Running Twenty Twelve, Apache2, no caching.

    I just got the problem to go away by turning on script debugging

    I added

    define(‘SCRIPT_DEBUG’, true);

    to wp-config.php

    And now the toolbar in the visual editor pops into place where it should.

    Instructions here:

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    …say to report this to developers. And so I have. Should this be a separate post? Don’t know.

    -r

    I am also experiencing this same issue with a site that was previously working prior to the upgrade. What I’ve found is that if I remove any calls to the “remove_menu_page” function from my theme and plugins, the media browser works again. Hopefully this helps some others.

    Further exploration revealed it’s not the remove_menu_page but perhaps the hook I was using (which was wrong). I was using the “admin_init” hook to remove the menu pages, changing it back to the correct one, “admin_menu” fixes the media browser and still allows the remove_menu_pages function to work properly.

    I have the same problem:

    – Add Media
    – Upload new image (which works).
    – Add all the information.

    When I hit “Insert into Post” it does NOTHING.

    I Disabled ALL plugins and tried again. NO CHANGE.

    It’s not a plug-in issue.

    I added this to my wp-config.php file, as described above:

    define(‘SCRIPT_DEBUG’, true);

    and that solved the problem of no editing toolbars and not being able to edit widgets and so on.

    I had already tried disabling all plugins, switching to the default theme, and all the usual stuff, and none of that worked. But after adding the line above, I restored all plugins and my custom theme and all worked again.

    When I checked the Error Console in Firefox, I saw that most of the errors were coming from bad code in the Gravatar CSS files as well as other files I have no access to.

    Just removed and re installed WP and brought over the plugins. Called it back up and still cannot get the images to populate in the editor box.

    Tried on Firefox and Chrome.

Viewing 15 replies - 1 through 15 (of 18 total)
  • The topic ‘WP 3.5 Visual Editor Broken, Can't Insert Media, No Editing Tools’ is closed to new replies.
Skip to toolbar