Support » Fixing WordPress » WP 3.5 upgrade admin drag-drop and editing not working

  • Resolved Mvd



    On one install of wordpress I encountered a problem with javascript (it seems) in the admin area after upgrading to 3.5!
    All the widdgets expand/dragdrop etc hangs, the MCEditor not switching between visual and text mode and dashboard items not expanding.

    I rolled back to previous version and reinstalled 3.5, to no avail.
    On the front end everything works fine, the plugins as well.

    Anybody knows how to fix this?

    When I rename the plugins folder to plugins.hold the wordpress install works fine again, but when I rename the plugins folder back to plugins the problems reoccur.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Ok, I fixed this:

    It seems to have had to do with eighter jetpack or WordPress SEO plugins had to be upgraded (which I did) but I also disabled a couple of unused plugins.

    Somehow this made the difference!

    I noticed the Widgets Drag and Drop completely die so the javascript on that is clobbered in Appearance -> Widgets

    Tried another site – pre upgrade – I could drag and drop to my little hearts content… Upgraded to 3.5 – BANG! Dead in the water.

    I’ve disabled ALL Plugins and still no joy on both sites.

    I’ve not had the time as yet to dig into this as yet but is anyone experiencing this?

    @michiel – Glad you got it sorted but seems it’s not a plugin issue for myself BUT in both cases I had upgraded WP Before upgrading any plugins and then deactivated them, but I don’t see that as the issue ( he said!!! )

    With your plugins deactivated… are you manually emptying your browser cache before checking the widgets?

    If it doesn’t work with ALL your plugins deactivated… after manually emptying your browser cache… then switch to the default twentytwelve theme. Again… manually empty your browser cache… and try the widgets again.

    Well I lept onto another site and upgraded then deactivated all plugins – running WP 3.3.2
    Then upgraded it to 3.5 and that appears to be ok.

    All 3 sites are completely different in their “upgraded from” version and the plugins used, so no pattern I can see from that…

    @josh – I’ve tried what you suggested and still no joy on the site this first showed up on. Using Firefox at the moment!

    So one site seems to be completely Javascript Challanged.. The 2nd will at least let me type in the broken WYSIWIG and the 3rd has no problem at all.

    The First site – makes an attempt to read in an existing post… The Sidebar comes up and it makes an attempt to write it but then goes blank!

    Seems that not ever having a problem with this in the umpteen years I’ve been using WP – it’s my turn 🙂

    I’ll have to play with this later and get serious working out what’s going on!


    True dat!! 🙂

    Also, it may help to enable wp-debug. If you’re working with all your plugins deactivated… then the only notices or warnings which would be thrown would either belong to the theme… or to WP.

    At least you would know what direction to focus your efforts.

    I have the same problem – very frustrating

    WordPress 3.5

    I have de-activated all plugins

    I have activated the 2012 theme

    Can’t drag and drop menu items

    Can’t ‘Switch to the multi-file uploader.’

    Can’t change the Publish Status or Visibility

    Moderator Andrew Nevins


    Front-end developer


    As you’re not contributing to the original poster, consider creating your own thread on the issue and referring this thread if necessary.

    The same occured after I made the update to 3.5

    (I use Firefox 17.0.1 )

    (I have deactivated my browser-cache by default, so this trap is not one for me, but who’s cache is active indeed should empty it, like Josh wrote (more than one times))

    I deactivated serially all plugins.


    I use on the related site a plugin which is called

    Smart Slideshow Widget
    Version 2.7.4

    After I deactivated this one, all below described effects stopped.
    (Hope it will help)

    No drag and Drop
    No html-view in editor
    no image insert possible
    no download insert possible

    And a lot of thanks to you guys, you helped me really out a lot of times!!!!!!!

    Thanks to everyone for adding to this…
    At least it confirms… for the time being… I’m not going completely mad!

    I’m just getting back into digging into this a bit deeper…
    But on initial testing I get the following…

    Firefox – Post WYSIWYG Dead – Widget Dragging Dead
    Chrome – Post WYSIWYG Dead – Widget Dragging Dead
    Konqueror – Post WYSIWYG Functions – Widget Dragging Dead
    Of course this is all under Linux… Which shouldn’t be a factor!

    Just to Clarify the DEAD WYSIWYG – I just get the basic text area box and the Visual and text tabs and cannot even type in it.

    What is interesting that under Konqueror it works like a bought one…
    That is just the editor – not the drag and drop for the widgets.
    There’s a clue in there somewhere lurking!

    I’ll see if I can get a working blog again for Christmas!


    I have four websites working with WP. To all of them the upgrade to WP 3.5 had been performed on 14th December automatically.

    With 3 of 4 websites there were no problems. One became complicated.
    There are no differences in server configurations between the sites, pHp 5.4 (sorry, I’m biologist and don’t no, what information might be important for the description of the situation).

    All websites uses the same 4 plugins: Change Memory Limit, Google Analytics, WordPress importer, WP-optimize. All plugins are up-to-date.

    Differences and results after WP upgrade (URL – theme – result) – Suffusion ver 4.4.3 – Everything OK afer update – Sundance ver 1.1 – OK – Esplanade ver 1.0.9 – OK – Arjuna X ver 1.7.1 – PROBLEMS

    The problems are with writing the new posts. I couldn’t add the picture here to the forum, so there is the link of the screenshot at the picasa storage. At the screenshot I marked all the not-working places with red circles:
    1. Not possible add pictures to the post
    2. Not possible add tags to the post
    3. Not possible change some screen options of the admin panel
    4. Not possible turn HTML editor
    AND 5. Not possible the automatic upgrade to english 3.5 vertion

    The same situation with different browsers: IE, Mozilla, Chrome, Opera (versions are up-to-date).

    After the unsuccessful automatic upgrade I upgraded WP for manually following the instructions. The result is the same.

    Moderator Jan Dembowski


    Brute Squad and Volunteer Moderator

    Guys? Rather than just jumping on this topic (and making more of a mess of this one too) please start your own thread. Michiel’s problem was solved a week ago.

    It makes it really difficult for us volunteers to focus on your problem when we’re all working on three different people’s set ups. Review the master list, check for Javascript errors and then please start your own topic.

    How-To and Troubleshooting

    Despite similarities your problems are not the same and may require different specific solutions.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WP 3.5 upgrade admin drag-drop and editing not working’ is closed to new replies.