WordPress.org

Support

Support » How-To and Troubleshooting » WP 3.5 Media upload HTTP error.

WP 3.5 Media upload HTTP error.

  • I can’t get the Media uploader to work. This is on some sites I updated but also on a clean install using Twenty Twelve and no plugins.

    My host (VentraIP) insist it is not them. I had no problems with earlier versions of WordPress.

    I have tried FireFox and Chrome on Windows 7.

    I added

    define('CONCATENATE_SCRIPTS', false );

    to wp-config.php but it made no difference.

    I cleared my browser cache but it made no difference.

    I have tried small and large images – made no difference. Occassionally they upload.

    When it errors they are actually in the media library when I check but something is wrong with them, no thumbnails have been generated.

    If I try to edit an image (as in crop) it says:
    Image data does not exist. Please re-upload the image. or I get a broken image icon or I get an out of memory error. Note I have set memory as high as I can in PHP.ini.

    My htaccess file:

    # Inserted By Customer Control Panel
    SetENV PHPRC /home2/drahorse/public_html
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /dev/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /dev/index.php [L]
    </IfModule>
    
    # END WordPress

    PHP.ini file:

    date.timezone = "Australia/Melbourne"
    disable_functions = show_source, passthru, exec, popen, proc_open, allow_url_fopen
    memory_limit = 256M
    max_execution_time = 120
    magic_quotes_gpc = on
    magic_quotes_runtime = off
    max_input_time = 120
    upload_max_filesize = 32M
    post_max_size = 32M
    extension_dir = "/usr/local/lib/php/extensions/no-debug-non-zts-20090626"
    realpath_cache_size = 128K
    realpath_cache_ttl = 120
    register_globals = off
    zend_extension = "/usr/local/IonCube/ioncube_loader_lin_5.3.so"
    extension = suhosin.so
    suhosin.executor.include.max_traversal = 6
    suhosin.apc_bug_workaround = On
    suhosin.memory_limit = 256
    suhosin.upload.disallow_elf = On
    suhosin.post.max_vars = 2000
    suhosin.request.max_vars = 2000
    suhosin.log.syslog.facility = 9
    suhosin.log.use-x-forwarded-for = Off

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi

    @esmi

    Forum Moderator

    If I try to edit an image (as in crop) it says:
    Image data does not exist. Please re-upload the image. or I get a broken image icon or I get an out of memory error. Note I have set memory as high as I can in PHP.ini.

    This definitely sounds like a server issue to me.

    My host has fixed jpg, PDF and png upload. Still waiting to hear from them what they changed.

    Gif files still give the same errors.

    i am getting this stuff too. some files upload and others dont.

    i deleted the database and the site completely and reinstalled wordpress.

    i am hoping its a server issue.

    esmi

    @esmi

    Forum Moderator

    @djc1210: As per the Forum Welcome, please post your own topic. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problem – despite any similarity in symptoms – is likely to be completely different.

    I only have the problem on my most recent installation. I have 3.5 installed on 4 other sites and media upload is working as it should.

    Same host, same registrar same everything else. Go figure.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘WP 3.5 Media upload HTTP error.’ is closed to new replies.