Support » Fixing WordPress » WP 3.4 Broken Visual & HTML editor.

  • Resolved velocity08


    Hi Everyone

    We upgraded this morning and once the upgrade had completed the visual editor & HTML editor are now broken.

    We had TinyMCE and this was upgraded to the latest version to be compatible with WP3.4 and to trouble shoot have removed the PlugIn.

    The problem still exists even after removing TinyMCE.

    We also cleared WP & browser cache to make sure it wasn’t a browser related issue.

    The issue is very noticeable when pasting in a HTML table the Editor seems to strip the first column from the table and then paste it above the actual table like in the example below:

    <td > <td >10GB<td >25GB<td >50GB<td >75GB<td >100GB<td >250GB<td >350GB<td >500GB<td >600GB<td >1000GB
    <table class="zebra3" style="width: 100%;" border="0" cellspacing="0" cellpadding="5" align="center">

    As you can see the first column is stripped out and pasted above the actual table.

    When disabling the visual editor for my profile the HTML kitchen sink is also missing from every section of WP and only leaves a blank area to paste HTML with no options for even the most basic editor.

    Any assistance with this would be greatly appreciated.

    Please let me know if you require any additional information.


Viewing 8 replies - 1 through 8 (of 8 total)
  • You were using a tinyMCE plugin or add on?

    Have you done the normal turning off all your plugins test?

    Hi Ipstenu

    Yes as mentioned in my original post the TinyMCE plugin is switched off and only the native editor remains or should I say whats lef tof it.

    I think i should have stuck to my guns and not upgraded as im desperate to finish a job i have been working on and now im playing “Fix That Problem” again. 🙁

    I Can also confirm that under a different profile the editor is still broken and stripping out the first column and pasting it above the table.

    This is what the HTML column looks like after its striped and replaced:

    <td >5GB<td >25GB<td >50GB<td >100GB<td >175GB<td >250GB<td >500GB

    Very strange behaviour

    “TinyMCE Plugin” is really vague 😉 There are a lot, you know.

    Perhaps (which has an update for WP 3.4 by the way)

    And when I said turning your plugins on and off… I meant all of them. Every last one. Yes, I know. But it may not be what you think it is.

    Well this is the strangest thing i have ever see.

    I have checked the table and code validated it with DreamWeaver & WC3 and they both came back with a thumbs up.

    I then tried to put in different table and this was not stripped.

    Went back to the original table and started dropping columns to test it and once i dropped the 1st column the table pasted in as it should be.

    I then manually recreated the data in 1st column and the column it self and low and behold it worked.

    I then re-enabled the Visual Editor & TinyMCE (TinyMCE Advanced 3.49) and the editor is working again.

    I have not encountered this behaviour before, it looks like it may have been a code issue but i dont understand how as validation came back 100% and prior to the upgrade the table was working just fine.

    Ill mark this as resolved but have no idea where the actual problem stemmed from.

    Thank you Ipstenu for your assistance with investigating this further.

    This isn’t fixed. I’ve deactivated all of my plugins and the visual editor is still broken.

    I default to the HTML tab when I try to write a new post. When I click Visual, nothing happens.

    Has anyone been able to resolve this issue? I’m using TinyMCE advanced… just re-installed the newest version and can’t access the ‘visual’ editor, only the HTML (text) editor. I’ve deactivated the plugins and reactivated them, both via wp-admin and FTP.

    Is there another solution?

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP 3.4 Broken Visual & HTML editor.’ is closed to new replies.