WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WP 3.3 Install failed HELP!

[Resolved] WP 3.3 Install failed HELP!

  • Help when I tried to automatically update WP (which had always been smooth as silk) it kame up with:

    Update WordPress

    Downloading update from http://wordpress.org/wordpress-3.3-no-content.zip…

    Unpacking the update…

    Verifying the unpacked files…

    Installing the latest version…

    Warning: copy(/home/xxxxx/public_html/xxxx/wp-admin/includes/screen.php) [function.copy]: failed to open stream: Permission denied in /home/xxxxx/public_html/xxxx/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Warning: copy(/home/xxxxx/public_html/xxxx/wp-admin/includes/screen.php) [function.copy]: failed to open stream: Permission denied in /home/xxxxx/public_html/xxxx/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Could not copy file.: /home/xxxxx/public_html/xxxx/wp-admin/includes/screen.php

    Installation Failed

    What can I do?

    Thanks for all and any suggestions.

    GV

Viewing 10 replies - 1 through 10 (of 10 total)
  • esmi

    @esmi

    Forum Moderator

    Try:
    – switching to the Twenty Eleven theme by renaming your current theme’s folder in wp-content/themes and adding “-old” to the end of the folder name using FTP or whatever file management application your host provides.

    resetting the plugins folder by FTP or phpMyAdmin.

    – re-uploading all files & folders – except the wp-content folder – from a fresh download of WordPress.

    – re-running the upgrade via wp-admin/upgrade.php

    Cannot log in, tried fix:

    renaming plugins directory
    creating new “plugins” directory
    still cannot log in to dashboard – though I can see my website

    You’re very kind Esmi, I will try that right now.

    Thank you.

    While Filezilla uploads the two directories (except wp-content, as you said) may I ask whether I can run upgrade.php from cPanel’s File Manager, and how?

    Thanks again (biting the last of my nails)
    GV

    I tried running it directly from the URL

    http://xxxxx.xxx/wp-admin/upgrade.php

    and got

    Warning: require_once(/home/lgbtbris/public_html/lgbtwp/wp-admin/includes/screen.php) [function.require-once]: failed to open stream: No such file or directory in /home/xxxxx/public_html/xxx/wp-admin/includes/admin.php on line 37

    Fatal error: require_once() [function.require]: Failed opening required ‘/home/xxxxx/public_html/xxxx/wp-admin/includes/screen.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/xxxxx/public_html/xxxx/wp-admin/includes/admin.php on line 37

    esmi

    @esmi

    Forum Moderator

    You are still missing files. Delete the wp-admin and wp-includes folders on the remote server and re-upload then from a fresh download of WordPress.

    Done all that… and got a blank page, but when I went to the wp-admin page, I found a lovely little notice waiting for me, telling me the database would need to be updated, clicked on the button and … voila’! MAGIC! My site was back! (does little dance).

    Reactivated all the plugins and my site’s more or less back.

    Thank you, thank you thank you Esmi, you’re the best!

    Where do I donate? 🙂

    big hugs

    best of the Best
    Gea
    xx
    PS Happy Solstice, Christmas, Diwali, Hannuka, or just plain happy holidays… whatever suits!

    (It’s good old Winter Solstice for me! 🙂

    This problem on my system was because install.php’s permissions differed from all other files. How and why install.php gets written is curious because it is apart of the update process. Why it got written with permissions that differ from the typical plugin installation is where I’m having trouble. While I can fix the problem by updating wp-admin/install.php’s permissions -how it got them wrong is a mystery.

    Hello Steve,

    perhaps you could report it in Bugs? I am not in a position to explain or fathom what was wrong, but it sounds as though you do… so perhaps reporting it will fix it in the next update.

    Thanks for taking the time to post, though.

    Have a great holiday!

    GV

    Hi all,
    I’m running into the same problem…copy(D:/Inetpub/xxxx/wp-admin/includes/update-core.php) [function.copy]: failed to open stream: Permission denied in D:\Inetpub\xxxx\wp-admin\includes\class-wp-filesystem-direct.php on line 200 –

    It’s not giving me any more info than that… How do you diagnose the issue? It seems this problem can have a number of possible causes…?

    I updated the plugins – ran into trouble with TrackThatStat, which is no longer appearing on the Installed plugin list, active or otherwise. I would delete it, but can’t find it to do so…

    This is coming in the larger context of a 3.3 update hanging. I should also mention that the client for whom I’m doing this has a 14,000+ -name “user” (blog subscriber) database, which I suspect has a large amount of deadwood (no filtering function applied). Could that be part of the problem?

    Can anyone tell me how to identify and resolve the problem here? Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘[Resolved] WP 3.3 Install failed HELP!’ is closed to new replies.