WP 3.2.1 upgrade breaks homepage menu bar for just one WPMU site (10 posts)

  1. ashschroeder
    Posted 4 years ago #

    http://owaa.org is a WPMU install. A recent upgrade to WP 3.2.1 broke just one of the WPMU sites. The menu bar of http://www.owaa.org/ou looks like this: http://owaa.org/wpmu-menu-bar-problem.jpg. Hovering over the home button presents what looks like a CSS problem, but you can't click on it, either. Yet, you can hover/click on the second menu item just fine.

    What troubles me is that this site uses the same theme as all the other WPMU sites, yet it is the only site is having problems with the menu bar.

    My hosting service said this, though I don't really know what the error means:

    "I investigated a bit further on this to try and provide you with more options to work on getting this resolved. I was able to connect through the WordPress admin and pulled the following PHP error from the log as I visited the homepage. It seems to indicate lingering database errors:
    [05-Sep-2011 10:57:52] WordPress database error Incorrect key file for table
    './beta/wp_8_postmeta.MYI'; try to repair it for query SELECT SQL_CALC_FOUND_ROWS
    wp_8_posts.* FROM wp_8_posts LEFT JOIN wp_8_postmeta AS miniposts_meta ON
    (wp_8_posts.ID = miniposts_meta.post_id AND miniposts_meta.meta_key='_mini_post' AND
    miniposts_meta.meta_value=1) WHERE 1=1 AND wp_8_posts.post_type = 'post' AND
    (wp_8_posts.post_status = 'publish' OR wp_8_posts.post_status = 'private') AND
    (miniposts_meta.meta_key IS NULL OR miniposts_meta.meta_value = 0) ORDER BY
    wp_8_posts.post_date DESC LIMIT 0, 10 made by require, wp, WP->main, WP->query_posts,
    WP_Query->query, WP_Query->get_posts"

    Troubleshooting I have done so far (with no fix to the problem):
    -Deactivated all plugins to see if this resolved problem.
    -Tried the TwentyEleven theme.
    -Reset the plugins folder by FTP.
    -Redo 3.2.1 upgrade (manually)... after first updating all plugins to current versions.

    Thanks for your help!

  2. Try running a repair on your database.

  3. ashschroeder
    Posted 4 years ago #

    How do I do that?

  4. ashschroeder
    Posted 4 years ago #

    I successfully followed those instructions but am still having the same problem.

    What would you suggest I do next?

  5. Did you check all the tables to repair? I would, at the very least, try to repair wp_8_* tables.

  6. ashschroeder
    Posted 4 years ago #

    The instructions said to just check the tables with overhead. So I did that and had no success.

    But I just went back and tried repairing all of the wp_8_* tables. I checked the site in IE and Firefox (on a PC) and cleared browser history, too. Problem still exists.

    Any other ideas?

  7. Ask your host. They're right, if it's barfing with "WordPress database error Incorrect key file for table..." then something's wrong with the DB, but I don't know enough to know what :/

    You may need to get a backup of your DB and copy the tables over.

  8. ashschroeder
    Posted 4 years ago #

    Shoot. Ok.

    I had actually started troubleshooting with my host before posting here. But then they said:

    The WordPress Codex is the next place I'd recommend checking for information if you want to post online there the WordPress admins are often much quicker at tracking down errors since they work with WordPress specific issues more than our Tech Support does.

    I guess I'll go back to them and see what they say. Will update this thread after I get a response from them.

  9. Yeah, sadly the only notes I have on that error is that a repair of the DB works: http://wordpress.org/support/topic/wordpress-database-error-incorrect-key-file-for-table?replies=5

Topic Closed

This topic has been closed to new replies.

About this Topic