Support » Installing WordPress » WP 3.2.1 update media / editor fixed

  • I’ve finally found a way to fix the quirks I was experiencing with the media select files button and the visual/html tabs in the editor.

    I’ve been reading all the posts on this subject and tried almost everything including updates the wp-config i.e.
    define(‘SCRIPT_DEBUG’, true);
    define(‘CONCATENATE_SCRIPTS’, false );

    Unfortunately I wouldn’t like to list all the places I looked but here’s just a few that you can link to:

    Here’s some of the titles for the others, you maybe able to find them using Google:

    • “wordpress 3.2.1” visual editor html tab not working
    • “wordpress 3.2.1” html visual editor problem
    • “wordpress 3.2.1” html mode problem
    • “wordpress 3.2.1” html tab visual editor problem
    • “wordpress 3.2.1” switching html tab visual editor problem
    • “wordpress 3.2.1” html tab problem
    • wordpress 3.2.1 switching html tab visual editor fix
    • wordpress 3.2.1 update visual editor fix

    Good luck if any the above help you.
    I followed as much of the instructions as I could and I also installed some plugins to try and fix the problem (as suggested):

    At least the “wordpress flash uploader” worked and the ‘script_debug’ did fix the media select files button.

    Unfortunately neither fixed the editor.

    I decided to follow the manual install instructions again when re-installing on my local machine using (which i’d already done and had success) xampp for windows

    I kept the install simple and updated my wp-config as normal.
    Voila it worked! The image uploader worked, meaning the flash select file button worked. Also the editor worked.
    Well of course it always did but it was just the reassurance I needed to know it was still a very simple process.

    I followed the exact process on my virtual host. I created the database and database user exactly the same way.

    I didn’t use the fantastico/cpanel option. I just extracted (unzipped) the files into a chosen directory and performed the same manual install. My host allows me to extract on the host using the file manager. So i just uploaded the wordpress zip file using FTP.

    I uploaded my local machine’s wp-config, which I first edited to match the database online because my virtual host put a prefix before the database name e.g. prefix_my-db-name.

    After the same process was followed I checked the same areas that had the issues previously i.e. image upload and visual editor tabs and the problem were still there. Meaning the ‘select files’ button was not found and the visual editor html tab was still not working.

    So the final step was left which is to import the database backup, which contained only the basic installed tables, default template and plugins.

    Drum roll…

    Drum roll…

    It worked! The WordPress installed on my virtual host is now working exactly the same way as my localhost!

    No messing with deactivating plugins or installing new plugins or changing themes or uploading jquery files or copying fresh files using FTP!

    Just a simple installation using the manual install process and importing my local machine database.

    Good luck I hope the same will work for you.


Viewing 4 replies - 1 through 4 (of 4 total)
  • Also I am happy to share my PHPINFO just incase you have any questions about this because I also read there are others having problems with JSON of their PHP version.
    Just let me know.
    Although my media select files button is now working I still chose re-install the following plugin ‘wordpress flash uploader’.
    The above link also goes to the wrong place.

    Just another update, which is regards to updating your new installation with all your data for pages, posts and categories (taxonomy) etc.
    You should update these tables separately.

    Create a separate backup file of the following tables:

    • wp_postmeta
    • wp_posts
    • wp_term_relationships
    • wp_term_taxonomy
    • wp_terms

    Not sure what’s the best way to perform a backup if it should be a CSV etc, but I use a SQL dump so some of the file information contains something like this:
    DROP TABLE IF EXISTS wp_postmeta;
    CREATE TABLE wp_postmeta (

    This works just fine and everything is still working! Yippee!


    Can I just summarise so far.
    I have found the problem to do with the database setup on the virtual host, not jQuery issues etc. It is also not connected with the auto install, because I began the process with manual install.

    I have found this process to be the most stable and successful way so far.
    It has fixed the problem with the image ‘select files’ button and the ‘visual html tab’, which is first experience

    1. Use the manual install process using .zip, but remember you will still see the issue
    2. This next part is when we fix the issue. You need to install wordpress on a local machine, because this is the only way I have been able to make this work in the simplest way.
    3. There is no need to add the following to your wp-config using this process:
      • define(‘SCRIPT_DEBUG’, true);
      • define(‘CONCATENATE_SCRIPTS’, false );
    4. Backup the local machine’s default database (which means nothing added or settings changed).
      • Change the database settings e.g db name, db user, db password
      • change any reference to the localhost URL where these settings are needed e.g in the options folder, which can be done using find and replace
      • .

    5. Backup the tables for pages, posts, categories etc. into a separate file.
    6. After manual install of wordpress on the virtual host import the 2 x database backups separately (I use phpmyadmin)



Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘WP 3.2.1 update media / editor fixed’ is closed to new replies.