Support » Plugin: qTranslate » Wp 3.1.3 qTranslate 2.5.21: editor broken

  • Hi!
    Some days ago I updated my wordpress site. After this update, when I tried to create and/or edit a post a message telling the qTranslate was disabled appear. It was ok, the version of qTranslate I had (the latest at this moment) was not tested with the latest version of WP.

    Today I updated the qTranslate to the latest available stable version, 2.5.21 and, after it, the editor crashed. I have the page in two languages, when I edit or create a new post, the to fields for the title in both languages appears but, the editor has no space to write anything!

    I would like to know how to solve it and/or know how to deactivate the qTranslate editor, I can write adding the qTranslate html tags to the post. But, with no editor, I cannot do anything.


Viewing 4 replies - 1 through 4 (of 4 total)
  • did you solve the problem? I found that deleting cookies can solve some problems with Qtranslate.

    I have the exact same problem after transferring my wp installation to a new server. It worked ok on the old one, but in the new one the text edit field is gone. Have also posted to the qtranslate forum about this but so far no replies – would be really grateful for all suggestions as installing everything from a scratch isn’t an option atm.
    I transferred everything as is, so nothing has been changed as far as I know… Everything else works perfectly.

    Hey, just tested with an older version (2.10) and now it gives me the text edit screen and the warning Alfons got originally, but when I click ‘activate’ (at own risk) the box is gone again.
    After that, I used the wp version automatic re-install, and then the older version was working after clicking activate. I then proceed to update the qtranslate, and now everything seems to be back to normal.
    This probably isn’t exactly the same problem as Alfons’s, as I changed servers, but might be something to try.

    I had the same problem with the missing editor, but I found out that it was caused by an incompatibility with an other plugin. In my case I was using WP Calendar. The editor were missing at the create new post-page and the calendar event pages. I tried to solve the latter by using an older version of WP Calender, but then I came to break the create new post-editor instead.

    I managed to solve the problem with WP Calender by making the following changes:
    wp-calendar/FormEvent.php: (added “titlediv”)

    >                               <div id="titlediv">
                                           <?php _e('Subject', fsCalendar::$plugin_textdom); ?>
                                           <input id="title"
                                                   value="<?php echo esc_attr($evt->subject); ?>"
                                                   style="font-size: 1.7em; width: 100%;"
                                                   <?php echo ($action=='view' || $evt->updatedbypost == true ? 'readonly="readonly"' : ''); ?>/>
    >                               </div>

    and inactivated qtranslate at the calendar administration pages by adding the follwing to my theme’s functions.php:

    if (is_admin()) {
    	if(($_GET['page']=='wp-cal-add') || ($_GET['page'] == 'wp-calendar/fsCalendar.php')) {
    		remove_filter('the_editor',					'qtrans_modifyRichEditor');

    Later I was building an own plugin, which had nothing to do with the editor, and the editor disappeared again.

    Apparently qtranslate uses the jQuery function jQuery(document).ready() to do its magic with the editor and if any other script run by jQuery(document).ready() causes a javascript error any following scripts will not run. A look at the browser’s javascript console may help to find the offending script.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Wp 3.1.3 qTranslate 2.5.21: editor broken’ is closed to new replies.