WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] [WP 3.1.3] Media Library stops working after upgrade

[Resolved] [WP 3.1.3] Media Library stops working after upgrade

  • Media Library stopped working after installing 3.1.3 security update. No thumbnails shown, but well known “No media attachments found.” message. Any help will be appreciated.

Viewing 15 replies - 1 through 15 (of 31 total)
  • esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    – checking your uploads path in Settings -> Media

    It works for me, though there IS a bug.

    ETA: And I’ve let the dec know about this one.

    No problem in my Media Library on upgrade, so far.

    So where does one direct those who have these problems? Should users even upgrade to 3.1.3 at all or wait for 3.1.4?

    Moderator Andrew Nacin

    @nacin

    Lead Developer

    luisantiago:

    Sorry about your troubles on this one. We managed to ship a small bug in the 3.1.3 release. (The only one, we think.) You hit a very rare condition — in fact, only about three or four plugins in the entire directory can trigger this condition.*

    Never fear, install a tiny plugin called “Hotfix” — http://wordpress.org/extend/plugins/hotfix/ — and all will return to normal.

    Sorry for any inconvenience,
    Nacin

    * Let me guess, do you have at least one of these plugins activated? Subscribe2, cbnet Different Posts Per Page, Gengo, or WP Multilingual.

    My Media Library is working, but I get the following warnings after upgrading to 3.1.3:

    Warning: explode() expects parameter 2 to be string, array given in /Users/capneb/Sites/blankfield.net/blankfield.net/wp-includes/query.php on line 2390

    Warning: in_array() expects parameter 2 to be array, null given in /Users/capneb/Sites/blankfield.net/blankfield.net/wp-includes/query.php on line 2399

    The second warning appears 8 times on my page when on the Media Library page or the image box is open (adding an image to a post/page with Media Library tab selected). All plugins deactivated. The warnings disappear after downgrading to 3.1.2.

    @andrew
    Installed hotfix plugin, problem solved. You guessed well: Different Posts per Page pulled the trigger.

    Many thanks to all of you who took care of my request.

    discern – can you try installing http://wordpress.org/extend/plugins/hotfix/

    The ‘Attachments‘ Plugin also had the same problem with 3.1.3, the same issue that discern described. Hotfix worked!

    I had the same problem as luisantiago and sure enough, the Different Posts per Page plugin was also causing the problem. Hotfix worked fine. Thanks to all!

    There is a bug in FeedWordPress plugin caused by 3.1.3. Downgrading solved it. Maby Hotfix will also work.

    Also this plugin stopped working I think:
    http://dev.huiz.net/2010/01/03/wordpress-plugin-scissors-for-v2-9/

    FYI, we NEVER suggest downgrading, as it doesn’t help anyone debug 😉 Re-upgrade and try the hotfix, please and thank you 😀

    Also, pointing out the obvious, that plugin says:

    Addition 27 Feb, 2011: The plugin WordPress for v2.9 is not available anymore. There is a new plugin, Scissors Continued, which will work from v2.9 and up.

    So does http://dev.huiz.net/code/scissors-continued/ work?

    Hi, I think I have some similar issue…
    My media library looks ok, but I’m unable to upload any new image on my posts.
    I’ve installed the hotfix plugin but it didn’t solved.
    I’ve also disabled all plugins, but it makes no difference.
    Any idea?

    Alexandru Burlacu – That’s a separate issue. Please make a new topic for yourself, and include any error messages you’re getting.

    The Hotfix plugin worked for me…THANK YOU SO MUCH! I was really worried there for a second..

Viewing 15 replies - 1 through 15 (of 31 total)
  • The topic ‘[Resolved] [WP 3.1.3] Media Library stops working after upgrade’ is closed to new replies.
Skip to toolbar