Support » Fixing WordPress » WP 3.1 Twenty Ten – Can't upload 940px header

  • Resolved blondie53185

    (@blondie53185)


    I am using Twenty Ten theme on a new installation of WP ver. 3.1. Attempting to upload a 940px by 127px header image. After the upload, it requires me to crop only 3/4 of it. If I upload a smaller image, it still requires me to crop 3/4 of it. Is this a bug, hosting problem?

Viewing 15 replies - 1 through 15 (of 26 total)
  • Are you uploading as a Header Image (Dashboard -> Appearance -> Header), or as a Post Attachment (Dashboard -> Add New Post (or Edit Post) -> Attach Image)?

    As Dashboard – appearance – header. Strangest thing I’ve ever seen. Here is another clue: When I attempt to upload another theme – sometimes it just freezes in the automatic process. Although, I have been able to add 1 or 2 themes – 3-4 others have frozen.

    Ok, I solved my theme install issue. Had to add an .htaccess file with AddType x-mapp-php5 .php in it. But my image problem has not gone away.

    Just out of curiosity: if you allow the image to be cropped, and then view the site, does the image render properly? Is it the right width/height? Is it distorted?

    It’s distorted. Is it possible to get this header in manually? Could I just upload it to my image library and then change the file that is calling it? Do you know where I would make this change?

    BTW, thank you so much for taking the time to help me! I really appreciate it.

    Interesting discovery: I just changed themes to Vina 1.3.1 by Nurudin Jauhari which also has a custom header uploader and get the exact same results. Hmmm.

    Given that you had to force your server to parse PHP as PHP5, I suspect that you might possibly have some other server-configuration related issues?

    I called the host (1and1.com – which may be my main problem, lol) and they insinuated it was a WP functionality issue. Do you have any idea what may be causing this on the server so I can hit them with an exact cause?

    Not really, unfortunately. It’s not really my area of expertise.

    Is your server running the GD Image Library? I think the Media Manager relies on it. Perhaps there might be a configuration issue there?

    I will call 1and1.com again and check. Thanks again for the help!

    I just got off the phone with the hosting company. They tried to recreate my issue by logging into my WP installation and uploading a 900px wide image to the Twenty-Ten header. They had no problem. I rebooted my computer and tried again. I am still having the same results – after I hit the Upload button, I am taken to a screen to crop the image.

    Does anyone have any suggestions?? You can see the image they uploaded to the site at http://unitsmilwaukee.com

    PS – I just tried this on my husband’s computer as well as IE. I had been using Firefox initially and thought it may be a browser problem.

    esmi

    (@esmi)


    Forum Moderator


    Have you tried uploading different images? With different extensions (.jpg, .png & .gif)? What happens if you simply click “Crop” after uploading an image?

    Can you try uploading an image from a different computer, or using a different browser?

    (What browser are you using, by the way?)

    This is really ridiculous! I am able to upload any other image without a problem. I have even recreated the image by copying for the original website – saving as .jpg, .png – using MS Paint and Photoscape. No matter what I do I cannot get this image in there!

    Suggestions? Is it possible the original image that I am grabbing has some sort of copyright coding in it?

    Chip – I did move to my husband’s computer and tried both FF & IE. Neither worked on his nor mine.

    esmi – When I click crop, the image is cropped and distorted.

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘WP 3.1 Twenty Ten – Can't upload 940px header’ is closed to new replies.