Support » Fixing WordPress » WP 3.1 – Problem Insert/edit link Button

  • The Insert/edit link button in the tinyMCE zone does not work: the pop-up window does not appear. However, all the other tinyMCE button work (bold, italic, etc…).

Viewing 15 replies - 1 through 15 (of 29 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – checking through the solutions suggested in Troubleshooting WordPress 3.1 – Master List

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the Twenty Ten theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Yes, I tried all this, does not work

    I encounter the same issue.

    Constructor Theme with plugings: Cufon, NextGengallery, e-commerce, audio link player, Youtube Embed.

    I’d hate to do major experiments now since the site has to stay live.

    For now my solution is to use the simple link button in html editing mode.

    I confirm the same issue with the Visual mode for my WordPress 3.1 / http://www.obviousidea.com

    but I also see it is browser dependant, it seems to work on firefox 3.6 but not with IE9 RC or Chrome.
    Can you confirm which browser version you are using ?

    I was having the same problem: not in the posts/page screens, but in my plugin’s submenu_page, in wordpress 3.1 in latest chrome,.

    I looked at the dif between the html in the posts/pages screens and my plugin page and I was misssing a hidden form for the links: (<form id="wp-link" tabindex="-1">) with the new “Enter Link” dialog, then I found this function:

    wp_link_dialog(); (in wp-admin/includes/internal-linking.php) which generates the output of the hidden insert-link form

    so I put it into my plugin with:

    add_action( 'admin_print_footer_scripts', 'wp_tiny_mce_preload_dialogs', 30 );
    add_action( 'tiny_mce_preload_dialogs', 'wp_link_dialog', 30 );

    & it fixed it, link buttons work now

    so could we consider it is a bug from chrome or from wordpress ?

    – I tried turning off all plugins and still had the problem. I did it using the phpMySQL method just to be sure.
    – I tried reinstalling WP 3.1
    – I’d heard that maybe it was a jQuery problem so I swapped in the jQuery code from WP3.0 under /wp-includes/js/jquery but that made no difference either.

    Interestingly, another instance of WP3.1 that I’m running with multi-site turned on (and the exact same plugins) does not have this problem.

    I have the problems with the link button with both Chrome and FF.

    on your page with the problem editor button, in your browsers “view page source”

    ctrl+f the snippet “<form id="wp-link"

    if it’s there – it’s for sure a jquery problem, and could be because of a non-3.1 compat theme (& not a plugin).

    Yep. There it was.

    I saw your post above and looked for /wp-admin/includes/internal-linking.php but couldn’t find that file.

    Any suggestions on what to do?

    if you’re missing /wp-admin/includes/internal-linking.php that’s most likely you’re issue, it contains the function that prints the linking-form that tinymce+jquery pops-up. directly adding the file may solve it, but if you’re missing that file you may be missing others, so a fresh copy of 3.1 may be needed

    http://phpxref.ftwr.co.uk/wordpress/wp-admin/includes/internal-linking.php.source.html

    Thanks, I replaced the /wp-admin/includes directory, but still no dice.

    Arrgh.

    Well I fixed it by stepping down to WP3.0-RC3. Not sexy, but it works!

    @davidsword: You are a hero! Thanks. Noticed the wplink.js file missing, didn’t discover that function yet. :))

    davidsword, can you help me out at all?

    I have the same problem as those above. I do have the internal-linking.php file. But when viewing source on the problem pages, I don’t have the “form id=”wp-link”” code.

    How can I get it added?

    it’s been a while, but i think i added this to my functions.php

    add_action( 'admin_print_footer_scripts', 'wp_tiny_mce_preload_dialogs', 30 );
    add_action( 'tiny_mce_preload_dialogs', 'wp_link_dialog', 30 );
Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘WP 3.1 – Problem Insert/edit link Button’ is closed to new replies.