Support » Fixing WordPress » WP 3.01 has stopped allow install of Plugins & upgrades

  • Resolved bschollnick

    (@bschollnick)


    Mysteriously over the last 3 days, WordPress has just stopped allowing the install of plugins or upgrading existing plugins via the automatic installer.

    The download appears to work fine, but it can’t create the folder for the plugin.

    Downloading install package from http://downloads.wordpress.org/plugin/post-footer-box.zip…

    Unpacking the package…

    Could not create directory. /home/bschollnick/schollnick.net/wordpress/wp-content/upgrade/post-footer-box.tmp/post-footer-box

    I have reset the permissions of wp-content, and wp-content/upgrade to 755. Applied recursive permissions to the plugins of 755 as well, without any change in behavior…

    I have deleted the upgrade folder, and allowed WP to recreated (recreated with my username, and 644 permissions, changed it to 744 afterwards for debugging purposes).

    The hosting company is basically stating that there’s nothing wrong. Any suggestions!?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The same thing has happened to me. I haven’t changed anything at all, and used to do updates just fine. Now I get an error saying that it can’t create the necessary files/directories in the upgrade directory.

    Tried recreating the upgrade dir with 777, no luck.

    If you did something three days ago (edited something or installed a new plugin) that may be the cause. If not then the most likely cause is a change/problem at the hosts end (which they have already denied). Try installing the WP System Health plugin to see if it shows any potential problems (such as low/incorrect PHP settings).

    Still having this issue. WP System Health shows nothing out of the ordinary.

    bschollnick

    (@bschollnick)

    Well, I didn’t see anything in WP-health that was wrong…

    As far as I can tell, AskApache Password Protect or WP htaccess Control seems to have been part of the cause… I remove removing AAPPro and it worked fine afterwards… But I’ve had that plugin loaded for quite a while… I don’t remember any recent updates, but…

    Now, I have to figure out why Akismet seems to be horribly bogging down the system…

    SecGen

    (@secgen)

    Thank…you…

    AskApache Password Protect was definitely the problem! There’s something wrong with that plugin.

    Finally… this issue has been breaking my head for the past few weeks.

    I think there’s more to it than 777 being the answer. If you set 755 under SuPHP, the permission used is “7” and 777 under DSO the permission used is “7” so in the case of 755 on SuPHP verses 777 on DSO, it is exactly the same thing! If you want to set something to 777, you set it to 755 on SuPHP. If you actually set it to 777, you instead actually set 000 —- NO ACCESS — oops!

    Dharmist

    (@dharmist)

    Had the same problem, and after doing some tests and debugging, found out that the problem was in AskApache plugin – it messed up some WP code after latest upgrade, apparently, so deleting it solved the issue.

    I solved my problem by putting this single line in my wp-config.php file…

    putenv(‘TMPDIR=’ . ini_get(‘upload_tmp_dir’));

    Guys, thanks a bunch. This was driving me crazy.

    Turns out AskApache Password Protect plugin was the culprit for me too. Deleting it has me updating WordPress again.

    Hey every one, I have fallen in a deadly problem! Can any one help me with thread http://wordpress.org/support/topic/a-deadly-problem-i-have-fallen-my-old-post-are-automatically-republishing ?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WP 3.01 has stopped allow install of Plugins & upgrades’ is closed to new replies.