WP 3.0 - Preview and Save Draft Functions not working (9 posts)

  1. jsiaw42
    Posted 6 years ago #


    Just to start of with a little background, I'm running 3 WP 3.0 installations. One is in the root directory, two are in subdirectories. Rather than upgrade, I installed them fresh today.

    My root directory installation is running fine, but with the other two, one is getting a 404 error when I try to preview posts and the other is giving me permission denied for preview and save draft.

    I have tried:
    - updating the .htaccess files (each has one in the subdirectory)
    - deactivating all plug ins
    - cleaning the db with GD Press Tools
    - making sure the URL and Blog name is similar and has www (even tried without www for both)
    - clearing the cache and restarting my PC (each time I tried one of the above methods)

    Since it doesn't happen to the root installation, I'm pretty sure it has something to do with the installation being in the subdirectory but I have no idea what to do aside from the methods I've described. Any solution would be greatly appreciated. Thanks!

  2. esmi
    Forum Moderator
    Posted 6 years ago #

    I'm running two 3.0 dev installs - both in sub-folders. Neither has a problem. Have you tried switching to the 2010 theme to rule out any theme-specific problems?

  3. jsiaw42
    Posted 6 years ago #

    Yup, I did that too. Anything else I can try?

  4. jsiaw42
    Posted 6 years ago #

    Still stumped. I have one blog running completely default now except for one exception. The Permalinks is set to /%postname%. At first I thought that might be the problem but even after I reset to default Permalink and cleared the cache and restarted the browser it still didn't help.

  5. jsiaw42
    Posted 6 years ago #

    I've managed to pin point the problem (I think). For some reason, my WordPress and Site URL MUST be the same for the preview function to work. I don't know why, since aside from making sure the format of both are similar it shouldn't cause any problems. This was what I was doing previously (without the quotes of course):

    WordPress URL: "http://www.primarydomain.com/blogurl"
    Site URL: "http://www.blogurl.com"

    This is the url generated by the preview link:

    Anybody have any ideas what could be the problem? Couldn't be something on the hosting side could it?

  6. ryssmiles
    Posted 6 years ago #

    I'd like to know if anyone has a solution. I'm having the same problem.

  7. avinashtjoshi
    Posted 5 years ago #

    I am also facing the same problem. Could someone give a solution??

    If the 'WordPress URL' and 'Site URL' are the same, I am able to see the preview of a draft post. But when they are different, I get a page not found error!

    This in my opinion is a serious issue.

  8. dizee
    Posted 5 years ago #

    I need to solve this issue also. My site requires the admin url be different than the main site and we are not able to preview posts because of this. Changing the URLs to be the same is not an option here...

  9. klivings
    Posted 5 years ago #

    I am running into the same problem, and hope I've narrowed it down to where someone can identify what's not working. I have a post I'm working on, ID 1195, and when I try to preview I get a "page not found" message. This is the link that the browser is looking for:


    If I go in and substitute the id of a published page, everything works fine for viewing that page:


    So, it appears that the link structure is fine -- the server can find the published page and display it, but it can't do the same for a page that has not been published. Why might that be?

Topic Closed

This topic has been closed to new replies.

About this Topic