WordPress.org

Support

Support » How-To and Troubleshooting » [WP 3.0] Menus item disappears after adding, does not save it

[WP 3.0] Menus item disappears after adding, does not save it

  • Hi ..
    I’ve installed a fresh copy of the WP 3.0 about 4 days ago. Using default twentyten theme- very nice drop down menu. I modified the menus from the admin panel with new pages and some custom links and hierchy… now everytime I modify the menu and click “Save Menu” it only saves the first 16 items listed on the menus.

    The problem is.. I have about 8 main menu with some of them have about 5 or 6 items below it, it cuts off at the 16th item and does not save anything beyond that.

    I deleted the first item and added two more at the end, same thing, it only saves the 16 visible items on the menus.

    Any help would be appriciated.

Viewing 4 replies - 1 through 4 (of 4 total)
  • I been sturggling on my own to figure this out, did search here and google yet to find a solution..

    I am shocked no one else is having this problem. I tried in IE7, IE8, Firefox, Chrome, Safari and Opera – I have the same problem no matter which browser I use.

    in function.php I am using
    //——————-

    register_nav_menus( array(
    		'primary' => __( 'Primary Navigation', 'MainNav' ),
    	) );

    //——————-
    and the page I want the nav on has thise code:

    <?php wp_nav_menu( array( 'container_class' => 'menu-header', 'theme_location' => 'primary' ) ); ?>

    is anything wrong with my codes?

    Should I report this as bug? I been searching for hours and can’t seem to find any solution at all.

    I am having this problem as well. I cant seem to get more than 16 menu items either in a child theme of twentyten. I have deactivated and removed all the plug-ins just in case there was a conflict and that didn’t help either.

    OK so I’m slowly beginning to realize that WP trac is better than these forums for troubleshooting. reference this ticket: http://core.trac.wordpress.org/ticket/14134 – the problem seems to be with your server and the max_vars it allows. I’ve contacted mine and hopefully the issue will be resolved.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[WP 3.0] Menus item disappears after adding, does not save it’ is closed to new replies.