The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

[resolved] WP 3.0: Can't login after allowing multi-site (8 posts)

  1. Nabha
    Posted 6 years ago #

    Maybe this should go in Trac -- if so, I'm happy to put it there, but I'm a bit intimidated by it! :)

    I set up a dev site for 3.0 beta 1 on a local server. Once I enable the multisite network and add this code, I can no longer log in:

    define( 'MULTISITE', true );
    define( 'VHOST', 'no' );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'anandadev-local' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    ... which is what WordPress says to add.

    I did follow all the steps that WordPress asked. URL rewriting is working great, too, using ISAPI Rewrite 3. FYI, we're using IIS 6 on Windows Server 2003.

    From reading other posts, a normal cause of this is an incorrect URL set for the site, but everything that way is correct.

    This has happened more than once on our dev servers, so it makes me very curious!

    Thanks for any help.

  2. Samuel B

    Posted 6 years ago #

    mine has one added parameter - maybe it makes a difference

    define('WP_ALLOW_MULTISITE', true);

    at the top of code you posted

  3. Nabha
    Posted 6 years ago #

    Yes, that was already in there. Should have mentioned it, but thanks for doing so.

  4. Nabha
    Posted 6 years ago #

    Looks like this is already known and being worked on. And there are potential workarounds:


  5. Did you upgrade your beta 1 to the latest nightly?

    (adding it to the exisiting trac ticket implies that you tested the last thing they added. ;) )

  6. Nabha
    Posted 6 years ago #

    Hi Andrea -- no I hadn't. I'll do that. (Thanks for all your work on MU, by the way. I'm thrilled at how easy it is to set up new sites, and how helpful it will be for everyone at our organization.)

  7. Nabha
    Posted 6 years ago #

    Update: Yep, still get the problem with the latest nightly.
    Double-update: Not 100% sure -- the database hadn't upgraded, to the latest nightly -- but it seemed like that.

  8. Not sure if the db needed an upgrade pers se, it only does that if there's some table fiddlin'.

    Just havign the new files over does it.

    (and you are so very welcome :) A lot of the work was done by wpmuguru.)

Topic Closed

This topic has been closed to new replies.

About this Topic