Support » Installing WordPress » Wp 3 mutisite pblm. Permalinks changed to /blog

Viewing 5 replies - 1 through 5 (of 5 total)
  • Moderator Andrew Nacin

    (@nacin)

    Lead Developer

    This is a known limitation when using multisite with subdirectories. It is why it most likely warned you about using subdirectories during the Tools > Network install, no?

    The main blog in a subdirectory setup is forced to use “/blog” currently.

    Dunno whether this still work.

    Go to /wp-admin/options.php, edit the permalink_structure to /%year%/%monthnum%/%postname%/

    Moderator Andrew Nacin

    (@nacin)

    Lead Developer

    It won’t, WordPress will continue to force /blog. There is a way to remove it using a plugin if I recall correctly, but it’s not a sure fix.

    It looks like this silly /blog/blog is inserted into the permalinks every time I edit my permalinks on the Settings–>Permalinks page. However when I go to Super Admin–>Sites and edit the site affected I can scroll way down to a permalink field there and remove the duplicate “/blog” from the permalink structure.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    IF YOU DO THIS, YOU WILL LOSE ALL CONFLICT CHECKING

    If you do this, you have to be VERY careful about never making a page that will conflict with your permalink settings, as well as any SUB sites, as WP will no longer be able to check for you.

    Go to Super Admin -> Sites and click on ‘edit’ so you go to http://domain.com/wp-admin/ms-sites.php?action=editblog&id=NUMBER (where number is the blog number).

    On that page, look for Permalink Structure and edit.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Wp 3 mutisite pblm. Permalinks changed to /blog’ is closed to new replies.