[resolved] WP 2.9.2 -- XML Parsing Error: XML or text declaration not at start of entity (10 posts)

  1. judah-mkp
    Posted 6 years ago #

    I'm past the edge of my knowledge about php. I'm wide open to any specific help you can offer.

    Here's the complete error for the RSS and comments RSS

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://mankindprojectjournal.org/feed/rss/
    Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?><!-- generator="WordPress/2.9.2" -->

    XML Parsing Error: XML or text declaration not at start of entity
    Location: http://mankindprojectjournal.org/comments/feed/
    Line Number 2, Column 1:<?xml version="1.0" encoding="UTF-8"?><rss version="2.0"

    I have tested every plugin, deactivating all at once and one at a time, without success.

    Seeking an excess line above "<?xm", I searched these files:


    Again, I'm at the limit of what I know how to do. Any specific help you can offer will be gratefully welcomed.


  2. Chris_K
    Posted 6 years ago #

    You're on the right track... but not looking for quite the right thing.

    Start with your wp-config.php file. Look for extra spaces or blank lines before the first <?php tag or after the final ?>.

    If that's not it, try changing to the Default theme. Does the problem go away? If so, look closer at your theme. Does it have a functions.php file? If so, do the same check as above.

    From there you'd go to the active plugins with the same check. (or disable 'em all while on the Default theme).

  3. judah-mkp
    Posted 6 years ago #

    Thank for the suggestions.

    On the wp.config.php file:
    Were no blank lines above the first "<?", and the file does not have any final "?>" (per the new convention for PHP files). Nevertheless, I removed all blank lines in the config file. The change made no difference. Still getting the same error message on the main RSS feed and comments RSS feed.

    As for the theme, you've found the source! I switched to WordPress Default 1.6 by Michael Heilemann, and instantly the RSS feeds worked perfectly!

    I then restored the existing theme, Revolution Code Blue 2.0 by Brian Gardner, and now both RSS feeds seem to be working again. More testing is needed by myself and others, but these simple action seems to have solved the problem.

    P.S. I sent a tweet to theme creator Brian Gardner to see if he's still supporting this theme, which we chose for the site in early 2009 after considering close to 100 other themes for our publication. Waiting to hear back from him.

  4. judah-mkp
    Posted 6 years ago #


    I just tested the feed in several browser: Google Chrome, Opera, Flock, and Camino on a Mac; Internet Explorer on Windows, and the feeds still did not work.

    So, now the feeds are working for me in Mac Firefox and Safari, but not any others.

    If the issue truly is the theme, where do I look in the theme files for the blank line?


  5. Chris_K
    Posted 6 years ago #

    Glad to hear you got it sorted.

    In the "small world" department, I'm in the midst of hacking up a theme based on Revolution Code Blue as well :-) I couldn't find mention of it anywhere on his site so I'm assuming he no longer supports it(?) but if you happen to find a version that supports threaded comments I'd love a link (I haven't tackled that yet on this theme).

  6. Chris_K
    Posted 6 years ago #

    Doh. I see we posted at the same time. Sad to hear you didn't get it sorted. Just tested with my version of the theme and the feed looks OK.

    Looked closer at yours though... At the top you have:
    <!-- generator="WordPress/2.9.2" -->

    preceded by a blank line. That definitely shouldn't be in your feed! Has your WordPress "main" index.php been modified?

  7. judah-mkp
    Posted 6 years ago #

    I just went into the functions.php file of the Revolution Code Blue theme itself, removing every blank line in the code.

    The feed now works in Mac Navigator, Mac Firefox, Mac Safari, but not in any other Mac browser (Chrome, Opera, Flock, Camino) nor in Windows Explorer.

    Where else in the theme could I look?

  8. Chris_K
    Posted 6 years ago #


    change the link from /feed/rss to just /feed and see what you get.

    Weird, huh?

  9. judah-mkp
    Posted 6 years ago #

    What apparently did the trick was switching to the default theme and then switching back. Yep, weird!

  10. danieltrezub
    Posted 6 years ago #

    Hi, guys.

    I am having an issue like this. However, my feed is empty after the update to 2.9.2.

    I use a small plugin to filter my feed to include just one category.

    the code is the following:

    Plugin Name: Feed Filter
    Plugin URI:
    Description: Filters your feed to include only certain categories.
    Version: 0.1
    Author: Daniel Trezub
    Author URI: http://www.gameblogs.com.br
      Copyright 2010 Daniel Trezub (email : xxxx)
        This program is free software; you can redistribute it and/or modify
        it under the terms of the GNU General Public License, version 2, as
        published by the Free Software Foundation.
        This program is distributed in the hope that it will be useful,
        but WITHOUT ANY WARRANTY; without even the implied warranty of
        GNU General Public License for more details.
        You should have received a copy of the GNU General Public License
        along with this program; if not, write to the Free Software
        Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
    function filterRSSQuery($query) {
    	if ($query->is_feed) {
    return $query;

    If I disable this little plugin, the feed works ok. If I enable it, the feeds does not validate and shows empty. Note that before the update to 2.9.2. everything was working great.

    Any ideas, please?

Topic Closed

This topic has been closed to new replies.

About this Topic