WordPress.org

Forums

WP 2.9.2, WP Super Cache, Permalinks, .htaccess, Comments (3 posts)

  1. npdeguzman
    Member
    Posted 5 years ago #

    My hosting account is with GoDaddy (Linux). I installed WordPress a month or so ago into a subdirectory of my website (http://essencelifecoaching.com/blog/). Yesterday, I updated the WordPress version to 2.9.2 and I installed the the Super Cache plugin.

    I found two problems so far: 1) Permlink Structure Error and 2) Posting a Comment functionality is broken. WP is looking for wp-comments-post.php in the root directory (http://essencelifecoaching.com/wp-comments-post.php) not the blog directory (http://essencelifecoaching.com/blog/wp-comments-post.php).

    My WP Super Cache Manager page has a error notification:

    "Permlink Structure Error

    A custom url or permalink structure is required for this plugin to work correctly. Please go to the Permalinks Options Page to configure your permalinks."

    I'm using the default setting in the Permalinks. How do I deal with the Permlink Structure Error?

    My .htaccess file is below, and the file has the following permissions: 1) Web user permissions = Read 2) Owner permissions = Read, Write.

    # BEGIN WPSuperCache
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    AddDefaultCharset UTF-8
    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{HTTP:Accept-Encoding} gzip
    RewriteCond %{DOCUMENT_ROOT}/essencelifecoaching/blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html.gz -f
    RewriteRule ^(.*) /essencelifecoaching/blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html.gz [L]

    RewriteCond %{REQUEST_METHOD} !POST
    RewriteCond %{QUERY_STRING} !.*=.*
    RewriteCond %{HTTP:Cookie} !^.*(comment_author_|wordpress|wp-postpass_).*$
    RewriteCond %{HTTP_USER_AGENT} !^.*(2.0\ MMP|240x320|400X240|AvantGo|BlackBerry|Blazer|Cellphone|Danger|DoCoMo|Elaine/3.0|EudoraWeb|Googlebot-Mobile|hiptop|IEMobile|KYOCERA/WX310K|LG/U990|MIDP-2.|MMEF20|MOT-V|NetFront|Newt|Nintendo\ Wii|Nitro|Nokia|Opera\ Mini|Palm|PlayStation\ Portable|portalmmm|Proxinet|ProxiNet|SHARP-TQ-GX10|SHG-i900|Small|SonyEricsson|Symbian\ OS|SymbianOS|TS21i-10|UP.Browser|UP.Link|webOS|Windows\ CE|WinWAP|YahooSeeker/M1A1-R2D2|iPhone|iPod|Android|BlackBerry9530|LG-TU915\ Obigo|LGE\ VX|webOS|Nokia5800).*
    RewriteCond %{DOCUMENT_ROOT}/essencelifecoaching/blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html -f
    RewriteRule ^(.*) /essencelifecoaching/blog/wp-content/cache/supercache/%{HTTP_HOST}/blog/$1/index.html [L]
    </IfModule>
    # END WPSuperCache
    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    It seems that if I enter the Permalinks Settings page w/o even re-setting anything, the .htaccess file is edited by WordPress and the 3 statements in between the # BEGIN WordPress and # END WordPress are deleted.

    This causes an error statement in the WP Super Cache settings page that states:

    "Mod Rewrite rules cannot be updated!
    You must have BEGIN and END markers in /home/content/n/p/d/npdeguzman/html/essencelifecoaching/blog/.htaccess for the auto update to work. They look like this and surround the main WordPress mod_rewrite rules:
    # BEGIN WordPress
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress"

    So, I re-edited the .htaccess file and added back the 3 statements.

    I'm kind of stuck at this point.

    Thanks in advance for your help on these two things.

    Noel

  2. npdeguzman
    Member
    Posted 5 years ago #

    PS. My General Settings for WP address and Blog address are http://essencelifecoaching.com/blog for both.

  3. npdeguzman
    Member
    Posted 5 years ago #

    I'm also noticing that the the url to the blog http://essencelifecoaching.com/blog is not hitting the page on some computers.

    Very confusing!

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic