Support » Installing WordPress » wp 2.9.1 class-simplepie.php installation errors

  • I used FTP to upload the files to a cPanel server. When I went to the dashboard I got the following error.

    Parse error: syntax error, unexpected $end in /home/webeddy/public_html/wordpress/wp-includes/class-simplepie.php on line 12153

    To test it I deleted the file and uploaded it again then got this error

    Parse error: syntax error, unexpected T_STRING, expecting ‘)’ in /home/webeddy/public_html/wordpress/wp-includes/class-simplepie.php on line 11515

    Tried replacing it a third time and got

    Parse error: syntax error, unexpected T_STRING in /home/webeddy/public_html/wordpress/wp-includes/class-simplepie.php on line 9455

    What’s wrong here and how can I get rid of this error message?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Hi Webeddy,

    I’ve also got a very similar problem with simplepie and I asked 4 days ago but so far no one has come back with an answer. My error message reads:

    Warning: main(/home/learning/public_html/wp-includes/class-simplepie.php) [function.main]: failed to open stream: No such file or directory in /home/learning/public_html/wp-includes/class-feed.php on line 4

    And like you, I want to fix this problem but have no idea how??

    Is there any way we can escalate a request for help in here because I’m learning WP and don’t know my way around yet?

    Can someone please help?

    Hi all,

    i also got a same problem.

    got “Parse error: syntax error, unexpected $end in /home/*****/public_html/wp-includes/class-simplepie.php on line 14290” in plugins and incoming links.

    hello, anybody can solve this problem?

    hello.. try this..

    http://wordpress.org/support/topic/306455

    reupload the file /wp-includes/class-simplepie.php

    Hi Vin,

    Thanks very much for that info ~ much appreciated 🙂

    I had already tried just reuploading the simplepie file but that didn’t work so I reuploaded the whole wp-includes and that is what worked.

    Thanks again for your help.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘wp 2.9.1 class-simplepie.php installation errors’ is closed to new replies.