Support » Fixing WordPress » WP 2.9 major problems with the editor

  • Resolved mediabaron


    Major problems with the new editor.
    1. When switching between Visual and HTML modes the HTML mode will remove all linebreaks and condense the text together and also displays all paragraph <p> codes. Makes it really difficult to edit body text in HTML mode. Yes, it looks fine in Visual mode but HTML mode needs to be working.

    2. Sometimes when publishing a post (seems like very often) all of the text of the post will disappear in the body copy. All that’s left is the title.

    I understand the editor was upgraded but it’s been causing plenty of headaches. I mostly use Safari on Mac (latest version) but I get the same problems if I used Firefox (latest version).

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Sigh. Every upgrade, somebody has problems with the stupid javascript editor code.

    The solution is always the same… Every single time.

    Step 1: Upload the WordPress files again manually. I don’t care if you think they’re there correctly or not. Do it anyway. It’s truly amazing at how many people think they’ve uploaded WordPress and in reality only uploaded half the files. I’ve seen it happen countless times.

    Step 2: Clear your browser cache. Close the browser. Reopen it to a blank page. Clear the cache. Then do it again. Then reboot the computer and do it a third time if you have to. It’s also truly amazing at how many people are capable of saying “I cleared the browser cache” and then, when I have them check, find it still has a thousand files in it. Clear the thing completely out, you have to make sure that you are getting all the latest javascript from the site.

    Step 3: There is no step 3. If you have successfully accomplished steps 1 and 2, then your problem is now solved. Contrariwise, if you still are having a problem, then you failed to accomplish one of steps 1 or 2. There is no other solution. There is no other debugging you can do. There are no other steps.

    What it comes down to is that if you have all the right javascript files on the site, and those javascripts make it to your browser, then your editor will work. How do I know this? Because it works for me. It works on my site, and in my browser. And it works on several other people’s sites, and in their browsers. So something has to be wrong either with your site, or with your browser. And realistically, we can’t help you debug those any further. We don’t have access to your site. We’re not running your particular browser on your particular computer. I’m not sitting there where you are. So other than telling you the above two steps, there’s very little debugging help I can offer you.

    Sorry, that’s just the way this particular “issue” always goes.

    Did all of those things. It now appears that the problem is with the way Safari 4.0.4 handles the editor. Firefox appears to be okay but Safari doesn’t work properly.

    Deleted cached files in Safari via both the drop down menu and also digging down into Library to delete cached files. Anybody else having this issue with Safari on Mac?

    I’m going to test Safari on Windows next. Google Chrome seems to work okay.

    I think I may have found the problem. Google Gears was messing things up. I thought it was disabled since I moved to Snow Leopard. I went ahead and deactived it in Safari, went through yet another round of emptying the cache while no windows were open, went into my Library subdirectories and wiped-out any traces of Safari cache and now it seems to be working. I’ll update if it breaks again.

    Thanx for the info Otto42…patience is ALWAYS rewarded….

    Otto42, I appreciate your oh so annoyed comments very much, and have followed your directions to the T. I maintain about 10 WordPress sites, and when the call came for the upgrade to 2.9, I did so, but some of them went fine, and some of them did not.

    For the one that did not (visual editor broke) I have just followed your 2-step instructions. I downloaded fresh 2.9 code, and manually uploaded it to the site where the TinyMCE editor is now failing, flushed my caches, and nothing changed. The TinyMCE editor did NOT repair itself, and you telling me I did it wrong does not change the fact that I did it right, or at least, exactly as you specified. Since it was working before 2.9 came along, and is not working now, the fault is wp 2.9’s, not mine.

    I have also done the usual uninstalling and reinstalling of all the plugins with fresh code too. This site is now all fresh brand spanking new code, and the TinyMCE editor is still not working, as we’ve tested it on multiple computers and multiple browsers.

    I wish that TinyMCE came as a totally separate plugin that we could activate, deactivate, delete, reinstall with fresh code, & reactivate at will — without having to replace all of our WordPress code just to do it.

    As it stands, however, it looks like unless you come up with a better answer, explanation, and apology for how 2.9 broke our TinyMCE editors, I am replacing it with the FCKeditor plugin, which works perfectly well, in some cases better — as I’ve seen on another of my WordPress sites — and IT came through the 2.9 upgrade just fine.

    For the 2.9 bug report — TinyMCE comes up fine when adding a new page, but refuses to come up when editing some, but not all, existing pages. I’ve spent enough time on it for one day. If I could tell you more, I’d be on your payroll.

    My fix is to replace TinyMCE by installing the FCKeditor pluglin.


    Thanks Suzanne,
    My story is almost identical to yours. Thanks to your suggestion, I’ve installed the FCKeditor editor as well.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Did you empty the Gears cache as well? If you’re using Gears, I mean.

    Try disabling Gears.

    The short of it is that if your TinyMCE editor isn’t working, then the problem lies in one of two places: Your site not transmitting the files to your browser (which does not involve WordPress at all, BTW), or your browser not getting the files from your site (which also doesn’t involve WordPress).

    Unfortunately, it’s that simple. Nothing WordPress can do will “break” your editor, because, and this is very important to understand, WordPress is not involved with the editor’s functioning in any way.

    The TinyMCE editor is a series of Javascript files that enhance your editor in the browser. Those javascripts are served directly to the browser from the webserver. WordPress just says “here’s where the files are” and that’s it. It doesn’t do anything to affect the editor at all except for static configuration stuff that is the same on every site. So it can’t break the editor on some sites but not on others. It’s all or nothing. What can break the editor on a specific site is any kind of javascript errors or files not being loaded by the browser or things of that nature.

    So be mad at WordPress all you want, it’s just misdirected anger. We can’t help you fix the problem because it’s not a WordPress problem. It’s a server problem, or a browser problem, or possibly a problem with some other plugin interfering with your javascript… But it can’t be a WordPress problem. The editor simply does not work that way.

    Hi. I have a previous version of WP running no problems. I just installed WP 2.9.2 today on another server and I have this problem. The editor won’t accept paragraph breaks, everything comes out with only a line break. Hit return 10 times, save, and you only get a line break. I’ve reinstalled all the files and checked on different browsers on a Mac and PC but still the same problem. I’m now out of ideas!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP 2.9 major problems with the editor’ is closed to new replies.