Support » Fixing WordPress » [WP 2.8.4] – media uploading: “Error saving media attachment.”

  • Hello,

    After doing a fresh install of WordPress 2.8.4 I got the following error while trying to upload media to the library:

    Error saving media attachment.

    After reinstalling thrice I got this feeling there was nothing wrong with the files. I downloaded a new WordPress copy from each time.

    After some googling and search in found more people complaining about this and apparently people have been changing the uploads directory permissions to 777.

    1. Is this secure? Having the uploads directory with 777 will allow anyone to do whatever they want with it or am I wrong?

    2. Also, I tried it once and then set the directory back to what is was: 755. I noticed that the photo I uploaded had permissions set to 666 which allows anyone to write. Once again, will this be secure or can someone just go there and mess around with the files?

    3. Is there another way around the problem that does not include turning off PHP safe mode?


Viewing 13 replies - 1 through 13 (of 13 total)
  • esmi


    Forum Moderator

    Try changing the permissions on the wp-content directory to 766. If you still have problems, try 767 or 777. Once your uploads are working, change the permissions on wp-content back to 755 again and check that everything still works OK.

    My upload directory is wp-content/uploads.

    I set both directory permissions to 777, uploaded an image, then set them back to 755. Now I can’t upload media again.



    Forum Moderator

    Possible mod_security problem?

    See point 6 on

    Tried doing what says on 6. and it is still not working unless the directory uploads is set to 777.

    Could this be a host problem?

    Also, the only media file I uploaded (while having uploads set to 777), an image, has its permissions set to 666 and I read that files should not be above 664 unless there was a good reason for it. Is this okay, will there be any security problems? My source:

    I recently started having this problem myself and I cannot for the life of me figure out why. I’ve tried checking the permissions for the folders in question. I’ve tried deactivating all of my other plugins to make sure there is no conflict. I even upgraded to the new 2.8.5 hoping that would fix it but it’s still broken. Every time I try using the browser uploader I get:

    “Error saving media attachment.”

    If I try the flash uploaded it says:

    “Unable to create directory /wp-content/uploads/2009/10. Is its parent directory writable by the server?”

    I am at my wits end… please somebody help me figure this out.

    Hi guys, Im having the same problem as CopperBot, is it a server issue?

    I’m having the same issues too, I was getting the same error message

    “Unable to create directory /wp-content/uploads/2009/10. Is its parent directory writable by the server?”

    Using my FTP client I found that there was NO directory called “uploads” at /wp-content/uploads/ so I created one and then put in it the directories 2009 with 12 inside that (it’s december now).

    I then FTPed the images I wanted there and used the MEDIA LIBRARY tab in UPLOAD. Nothing.

    I then tried to use the URL (I have wordpress on my site) to link to the same photo in my main site’s assets directory. Nothing.

    Have to admit that I’m new to blogging but fairly handy with websites and computers. I’ve also wasted more time than I want to at this stage reading many forum posts and playing around.

    I too am at my wit’s end 🙂

    Same problem here. Does anybody have a solution?

    same problem as above.i delete the database and create a new one.simply do it again from the the fine 🙂

    As I said in another thread changing permissions to 777 worked for me.

    hey supersnail,

    i have the EXACT same problem as you, and troubleshooted (troubleshot it??) it the EXACT same way as well.

    here’s what’s funny about my situation. the wp blog i’m having trouble with is at the ‘top-level’ domain. i have an ‘add-on’ domain within, AND that also has a wp blog. (both are set up EXACTLY alike.) guess what? the add-on domain works perfectly. i am now looking at a pile of hair i pulled out of my scalp, and i don’t even know what i’m going to tell the landlord about the kicked hole in the wall.

    this is nuts


    hey all at this thread…

    I think I may have found the answer for everyone here. (if you haven’t already 😉

    1. go to Settings/Miscellaneous
    2. In the “Store uploads in this Folder” type in the DEFAULT setting, which is:

    ” wp-content/uploads ” (w/o quotes, of course.)

    Everything worked (for me) after this ridiculously simple edit. I remembered it after taking a long walk to cool down and POW, light went off in my head. whew, now i can fix the hole in my wall and get a hair transplant 😉


    Changing the “Store uploads in this Folder” setting



    worked for me as well.

    Cheers, thealexangroup.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[WP 2.8.4] – media uploading: “Error saving media attachment.”’ is closed to new replies.