• This must be a bug introduced in WP 2.8.2 that attempts to fix the XSS vulnerability in comment author’s URLs.

    When I click “edit” on comments with existing comment author’s URL, the “Edit Comment” form comes up with an empty “website” field. And when I save the modification, the site URL is no longer there.

Viewing 8 replies - 1 through 8 (of 8 total)
  • esmi

    (@esmi)

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems.

    It’s not plugins. It’s the WP admin itself. It’s the admins “Edit Comments” form that loses the URL of the commenter.

    Anyway, I tried to disable all plugins and it wouldn’t help.

    It’s indeed a bug.

    I checked the change in the source files and found the bug in /wp-admin/edit-form-comment.php file.

    In the previous version they had a variable $url

    $url = get_comment_author_url();

    But in WP 2.8.2, they removed that line but still use the (now undefined) $url variable as a value of the “URL” edit box:

    <td><input type="text" id="newcomment_author_url" name="newcomment_author_url" size="30" class="code" value="<?php echo esc_attr($url); ?>" tabindex="3" /></td>

    Not sure how to submit it to WordPress developers. I checked the latest SVN version and the bug is still there.

    Thanks. Looks like the bug fix will be available in 2.8.3

    I too have just noticed this problem. I tried on other blogs I have, and believe it’s a bug. Thanks.

    I cannot edit comments at all after upgrading to 2.8.2.

    I deactivated all plugins, switched to the default theme, and I am still unable to edit comments.

    As an aside, I am also unable to add tags to posts. I can add them, but when I do “update post” or “publish”, they disappear again and are not added after all.

    Any advice on how I can remedy these?

    Nevermind.

    I used the solution given on this forum post: http://wordpress.org/support/topic/275443?replies=9

    It worked.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP 2.8.2 bug?’ is closed to new replies.