WordPress.org

Support

Support » Installation » WP 2.8 fresh install Fatal error: Call to undefined function wp_dashboard_setu

WP 2.8 fresh install Fatal error: Call to undefined function wp_dashboard_setu

  • I have tried many many many different permutations of fresh installations, installations with old configs, with or without plugins, anything I could think of but to no avail.

    I now installed WP fresh from the latest .tar.gz file.
    I ran the install script succefully.
    Blog created successfully.
    When I login with admin it gives me a page with just this error on it:
    Fatal error: Call to undefined function wp_dashboard_setup() in /home/sites/blog.bakabt.com/web/wp-admin/index.php on line 15

    Up to this point I have already tried many many many many many, I can not overexpress, many many many things to get this working.

    Chown apache * -R, chmod 775 * -R both have no effect.
    Yes all files exist.

    The only solution that I know is to disable APC (why? no idea).
    Adding wp- to apc.filters does not work.

    One peculiarity that I find useful to mention is the following.
    The above error occurs on wp-admin/index.php
    When I alter the require_once on line 13 to a require. Then duplicate that same line. I now expect a function-name clash, but no. It just gives me a white page (wtf?).
    Then if I enable error_reporting(E_ALL&E_STRICT) I get this error instead:
    Fatal error: Call to undefined function wp_cache_init() in /home/sites/blog.bakabt.com/web/wp-settings.php on line 299

    Can someone please tell me how to fix this?
    I will repeat myself if I have been unclear:
    THIS IS A FRESH INSTALL. Yes, all files are present (checked with file_exists). No, require_once does not seem to do it’s job. Yes, disabling APC works but is not an option for me.

    I must add that I am an experienced professional PHP programmer and I simply can not explain the above behaviour. It seems like somehow the cache is interfering. But the errors only appear when using require_once, when using require the behaviour changes radically.

    Help!

Viewing 15 replies - 1 through 15 (of 23 total)
  • I should add that I have not been able to find a single successful solution using Google. All threads seems to mysteriously die whenever this problem is brought up.

    Most solutions include:
    – Remove all plugins. Does not work for me as I have no plugins, fresh install. Moving the plugins dir has no effect (just to be safe).
    – Require files are missing. Required files are present, apache owns the files, chmodded to be sure.

    None of these solutions work for me.
    The only solution that works is to disable APC. Which is not a solution at all.

    I should also mention that the same behaviour, but a different error, occurs on WP 2.8

    Moderator Jan Dembowski

    @jdembowski

    Brute Squad and Volunteer Moderator

    It’s APC, what version is it? Going to the latest and greatest may improve the picture but you’ll still (probably) need to filter some things in the [apc] section of php.ini.

    Here are some APC issues and solutions that all point to adding filters in the [apc] section.

    http://wordpress.org/support/topic/225573?replies=5#post-1033606

    See update 3 on Marks blog
    http://markjaquith.wordpress.com/2006/02/13/adventures-with-wp-cache2-apc/

    None of these solutions work for me.
    The only solution that works is to disable APC. Which is not a solution at all.

    Not a solution? I guess that depends on if you want WordPress to work or not. Personally I use XCache but it’s your server.

    I have tried Mark’s solution already and it doesn’t work for me.
    I am not experiencing the errors mentioned on that page. I do not get a white blank page. I get a page with an error on it.

    I can not disable APC because other websites running on my domain rely on APC. That being said, I think it’s safe to assume that APC’s caching, is, or should be, transparent.

    Like I said. I added apc.filters = wp- and it has no effect.

    Still no solution ..

    Definitley an APC issue. Upgraded mine on the server to latest 3.1.2 and started to get the same messages as described above. Everything was fine in 3.0.19 (the last stable build) so i’m going to try downgrading to that instead, or tweak the config values for 3.1.2. Will report on findings…

    Chris

    I dont know if that solved your problem but I am still having this issue.

    I installed a brand new copy of wp2.8 and after I login as admin I am sent to a blank page. I also tried a copy of wp2.7 and it does the same thing.

    I checked and I do not have APC enabled.

    Had the same error message (Fatal error: Call to undefined function wp_dashboard_setup() in /www/…/wp-admin/index.php) on a more oldish WordPress 2.6.3 using APC but no WP-Cache. Somehow the line
    require_once(ABSPATH . 'wp-admin/includes/dashboard.php');
    in wp-admin/index.php seems to fool APC. It’s simply not included?!? I changed it to:
    require_once('includes/dashboard.php');
    and then I can login without disabling APC. Seems to work so far – but I see a number of require_once with ABSPATH included so it’s strange, really strange…

    Making that change worked for me as well. Thanks a lot man. 🙂

    What worked for me on OS X Snow Leopard with PHP 5.3 and APC was:
    [apc]
    apc.include_once_override=0

    HTH

    What is APC? How does this problem affect people on a hosted server?

    I’ll add to this that I got this same error out of the clear blue sky today. Replacing:

    require_once(ABSPATH . ‘wp-admin/includes/dashboard.php’);

    with

    require_once(‘includes/dashboard.php’);

    Resolves the issue. Any ideas why?

    I had the same problem as reyespoint, the error “just happened” this morning for two of our sites. Do you happen to also be hosted with a2hosting? I’m running WP v2.9.2. The changes to wp-admin/index.php did the trick. What could have caused this issue?

    Seeing the same error as per this morning & using A2 hosting!

    HI – I had the same problem – started out of nowhere last night! My wordpress blog is also on A2Hosting.com. While making that change did fix my problem with getting to my Dashboard, it left another problem for me…. I can not get to my Widgets! GO click on Widgets and see if that works for you. Let me know what you did to fix it if you fixed it… THANKS!

    SNAP – Got the same issue this morning. Using reyespoint mod seems to have fixed it, I also noticed some downtime with another A2hosted site I run.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘WP 2.8 fresh install Fatal error: Call to undefined function wp_dashboard_setu’ is closed to new replies.
Skip to toolbar