WordPress.org

Forums

[resolved] WP 2.6 Google Gears error (13 posts)

  1. Yemoonyah
    Member
    Posted 6 years ago #

    Hi there,

    I just upgraded and everything seems to be fine so far!!!
    I have just one little problem:
    Tried the google gears feature but get this message
    Error: Download of 'http://kabai33.com/wp-admin/images/align-center.png' returned response code 403

    What does this mean and how can I fix it?

    Grateful foe any help

  2. The permissions for some of your files/folders are set wrong. Fix them.

    http://codex.wordpress.org/Changing_File_Permissions

  3. Yemoonyah
    Member
    Posted 6 years ago #

    Thanks a lot!

  4. Yemoonyah
    Member
    Posted 6 years ago #

    I checked the permissions and they seem to be okay.
    The wp-admin/images is set to 755.
    The file "/wp-admin/images/align-center.png" is set to 644 just like the other align-left, align right... files.
    Should it be something else?

  5. Well, then, in that case, I don't know what the problem is.

    This: http://kabai33.com/wp-admin/images/align-center.png

    Should not return a 403 error. You need to figure out why it is. Maybe your host knows.

  6. Yemoonyah
    Member
    Posted 6 years ago #

    Okay, thanks anyway

  7. danahuff
    Member
    Posted 6 years ago #

    For the record, I'm having the same problem, and my permissions are set the same: 755 for the folder, 644 for the file.

  8. iridiax
    Member
    Posted 6 years ago #

    Do you have hotlink protection enabled?

  9. danahuff
    Member
    Posted 6 years ago #

    Yes, and I really don't want to disable it. Is there a change I can make to .htaccess to make it work?

  10. iridiax
    Member
    Posted 6 years ago #

    You could try allowing blank referers. Here's what I have for this:

    RewriteCond %{HTTP_REFERER} !^$

  11. sinistra
    Member
    Posted 6 years ago #

    Danahuff, iridiax - I'm having the same problem. I added the suggested line to my htaccess, but still no access (even after disabling and re-enabling gears)

    Edit: Spoke too soon! Disabled gears, emptied FF3 cache, restarted, re-enabled - success. Thanks.

  12. danahuff
    Member
    Posted 6 years ago #

    Worked for me, too. Thanks iridiax! By the way, for anyone coming by here with the same problem, I looked into it, and allowing blank referers is actually recommended in order to allow some visitors who are behind a firewall or antivirus programs to access the images on your site. See: http://www.htaccesstools.com/hotlink-protection/.

  13. Yemoonyah
    Member
    Posted 6 years ago #

    Thanks for the response!
    I did what you recommended and it works
    Thanks again!!!

Topic Closed

This topic has been closed to new replies.

About this Topic