Support » Fixing WordPress » WP 2.5 – WYSIWIG Problem – Can not ‘Insert Link’

  • Resolved jpxwordpress


    Immediately upon upgrading to WP 2.5 and trying to Write a first post, I could not get anything to appear at all in the pop-up window once I highlighted some text and tried to ‘INSERT A LINK’ while preparing a post…. Serious concern! Arg! Any ideas from anyone on what could be causing this / what the fix would be?

    Thanks so much.

Viewing 11 replies - 1 through 11 (of 11 total)
  • I have no solution, but curious as to what browser and version you are using?

    I have the same issue with Firefox on Windows Vista/32bit. This is a major deal breaker.

    I just tried in IE 6, 7, and FF 3b4. No problems here. I am assuming your a highlighting a word in the write box, and then clicking on the link button.
    Did you clear your cache after you upgrade WP?

    You mean browser cache? Maybe I will try that. Kind of crazy that you have to use a beta version of a browser to edit correctly in WP 2.5… I am beginning to think that the root of the problem I have been having (with the inserting of link and image) may lie in some kind of issue between WP 2.5 and the Firefox browser (at least At the same time, I am beginning to find more things about WP that I like, so I will continue to hang with it.

    Best of luck to everyone.

    Update on the problem inserting links and images using the WP 2.5 Admin Dashboard WYSIWIG editor:

    I downloaded the Mozilla Firefox 3 Beta 4 browser and it took care of this issue – now able to insert links, images, and embed media – fantastic (oh and this browser looks just ROCKIN too already….)

    Rock on WordPress (and yet another reminder of the need to ensure cross-browser/app/API compatibility I guess).

    Hmm. Beta 5 didn’t fix it for me, even after clearing the cache, and in fact the problem is showing up in every browser I’ve tried (3 Mac browsers and 2 Windows browsers). Cache clearing no help all around.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    This is not a new problem, and I thought people would have worked out that fact by now.

    This is almost always some kind of server issue. Look at your server’s logs, see what it has to say on the topic. Look for any errors related to wp-admin. Make sure that you uploaded all the WordPress files correctly. Disable mod_security.

    Whatever, but the point is that the error is not a browser error. They did indeed test it in all browsers. I’ve tested it on eight browsers on three platforms. Every part works in every one of them.

    Until you accept that it’s not a “bug” in the code but is instead some kind of issue on your specific setup, for your specific case, you’ll never fix it. We can’t help you until you accept that fact.

    You’ve got to be kidding me. That’s it? Try these random things and maybe you’ll find it? Please tell me we’ve got something more.

    I’m having a problem in Firefox when I add a link to text and check ‘open in new window’ it opens in the same browser window. Works fine in Safari. Using Firefox 2.0.

    You’ve got to be kidding me. That’s it? Try these random things and maybe you’ll find it? Please tell me we’ve got something more.

    Otto42’s reply was most unhelpful and flippant, especially when the issue is clearly not on the server side of things, but my experience with this bug is this: clear your browser history and cache. In Firefox, this can be achieved with Ctrl+Shift+Del on the PC, and Cmd+Shift+Del on the Mac.

    Maybe this helps or gives a hint to anyone:

    I had the same problem when accessing my wordpress installation over a SSL proxy to improve security. My webhost does not provide self-signed SSL certificates for free so I cannot access my domain securely with https://<mydomain&gt;. Instead I have to use https://<webhost-ssl-proxy>/<mydomain&gt;. Now when I use this url https://<webhost-ssl-proxy>/<mydomain>/wp-login.php the wordpress login page comes up over SSL. When I try to add a hyperlink the popup window is empty. When I do the login without the SSL proxy adding a hyperlink works fine, the popup windows shows content as expected.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘WP 2.5 – WYSIWIG Problem – Can not ‘Insert Link’’ is closed to new replies.