WordPress.org

Support

Support » Requests and Feedback » WP 2.5 Images upload problem

WP 2.5 Images upload problem

  • I’ve just upgraded to 2.5, and to my frustraition the text-editor fails any attempt to upload images to my posts. I get the red text stating that upload failed (sorry, I have norwegian language installed, so I don’t know the exact english error msg).

    It seams though, that the images are being uploaded to the server – which does not help mutch for users with no ftp access.

Viewing 15 replies - 1 through 15 (of 20 total)
  • I am getting the same thing. Checked my CHMODding and thats correct. It says its an HTTP error.

    Someone else posted this. It seems to work for me.

    Milquao, I am having the same problem. I spent 30 mins on one post.

    I just tried to upload an image and got the same message. Clicking the link in the window that opens just brings up the text-editor.

    Just upgraded a site to 2.5 (from 2.3.3) and also getting the HTTP error mentioned above. Not quite sure what is going wrong, haven’t changed any settings.

    http://trac.wordpress.org/changeset/7573

    This will fix that problem I think, but I still can’t upload with Firefox on Ubuntu.

    The solution in http://trac.wordpress.org/changeset/7573 still doesn’t solve the problem in Opera 9.26.

    I’m having the same problem with Firefox.
    Should be good once the kinks are ironed out though. 🙂

    I have updated 25 blogs now with 2.5 and have no problems. Image upload works fine. Did you deleted all old files (except wp-content) and copied the new over to the server? That’s what I did.

    http://trac.wordpress.org/changeset/7573 didn’t work for me on latest firefox stable even though I’d done the same installation as pepe-gonzales.

    Keep checking this thread for updates on the problem:
    http://wordpress.org/support/topic/164999

    Bloody hell… it was bad behaviour! And there was me reinstalling a test blog LOL.

    Thanks Otto42!

    Look forward to Bad Behaviours update!

    I get a different problem. When I click the insert image button, I get the javascript pop-up, but it is just an empty box — nothing to input.

    If I do it in HTML, it inserts the image, but then it seems to ignore any image class (such as align right).

    I get the same javascript error (blank box in the visual editor) when I try to insert a link as well.

    Any thoughts?

    I had a similar problem with my blog. Was fine until I upgraded to 2.5.
    If you have exhausted all other avenues, I would contact your host. My host (Hostgator) was blocking the upload of images for security. I had to tell them the location of all of my blogs so that they could remove the security feature. This worked perfectly.

    When I was getting the problem I was just getting “http error”, but I know some people got “crunching” instead.

    It seems that the server was logging this message: mod_security: Access denied with code 403. Pattern match “^Shockwave Flash” at HEADER(“USER-AGENT”) [id “***MY ID”][rev “1”] [msg “SpamBot UA”] [severity “CRITICAL”] [hostname “***MY-DOMAIN***”] [uri “/testing/blog/wp-admin/async-upload.php”]

    Hope this helps you guys. I spent hours trying sugegsted fixes. I never would have guessed that it was a security issue with my host. After contacting them it was fixed within the hour.
    At first they argued that it was 3rd party software, but I told them that I had a test blog and I also had blogs on 2 servers and it was the same on all of them. They referred me to their higher level support and they fixed it within an hour.

    Let me know the outcome. dave@isnigh.com

    We use WP for all of our sites. My wife is an artist, so uploading images is critical. After upgrading to 2.5.1 we’ve had nothing but problems with the Add Media routine. If you go to our site and check out this page: http://stermer-cox.com/?page_id=53 you will notice the difference in the first three images from the rest. Those were made with the new Add Media, all the rest with the old. The code it creates is different; the shading around them thumbnails is different; the thumbnails don’t size proportionally (yes, I have it selected to do that); and the alignment part doesn’t work correctly. I’m tempted to go back to the older version or to another software package altogether. I like WP, but with these kinds of problems, we may have to go to something else or I’ll have to go back to developing our sites ourselves.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘WP 2.5 Images upload problem’ is closed to new replies.
Skip to toolbar