Support » Fixing WordPress » WP 2.5 gallery won’t make some thumbnails

  • I’ve added a few images to my blog using the new Media Library tool without much trouble but I’m currently seeing a strange issue. Two images that I upload do not generate mid-size or thumbnail versions.

    It uploads the original and uses that image for the post. Whether I insert an image as thumbnail or with the [gallery] quickcode, I get the full size version only.

    Looking at my upload folder, I see there is no mid-size or thumbnail version of these two files like there are for other images I’ve uploaded.

    Any ideas?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Is there anything different between those images and ones they worked? Different file type? Really large file size?

    The file sizes are almost identical. Here’s a link to a post with the problem.

    The two black & white images are the problem images, so maybe there’s something in them that I can’t see.

    I tried one of the image on one of my test installs and it also wouldn’t make thumbnails. I then opened it in photoshop and saved it out again in case there was something wrong with the file and it now works. Give a try.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    Both of the problem images show up as having been saved as 8 bit grayscale JPG files. It’s possible that your copy of the gd image library doesn’t like those images for whatever reason.

    Next time, save them as 24 bit truecolor images instead, even after making them grayscale.

    i had a similar problem, some thumbnails were not displaying on the site only the original size image. But looking at the uploads directory, the thumbnails were actually created and uploaded.

    this would seem to rule out gd as the problem, true? any ideas where else it may be getting confused?

    note: i tried simply opening the problem images in gimp and saving, then they work fine.

    @hyper123 thanks, that seems to have helped. I think Otto42 has a point as to why (at least it worked). Thanks all.

    I’m having the same issue with some jpegs. The problem does seem to be related to gd choking on some files, with various results.

    I’m guessing that one of two things goes wrong:

    • sometimes no resized (thumbnail) image is output at all. In this case WordPress should give a meaningful error or at least show a default thumbnail image instead of the full size one. That’s really annoying since you only notice it when it’s too late.
    • sometimes a thumbnail file is output, but it’s not actually resized because gd failed somewhere without giving an error. This would me more difficult for WordPress to spot, but it should still be possible by checking image dimensions.

    As to why some jpegs work and why some don’t, that can be caused by many things. The most common problem with jpegs on the web in my experience is that they’re not in RGB but in Greyscale or in CMYK. Especially the latter can be tricky since it’s harder to spot and only fairly specialized software can reveal a jpeg’s color space (irfanview, for example).

    I’m getting the same issue – nothing I try to upload will show as a thumbnail. All that shows is the full-sized images, all overlapping. It looks like the formatting is right, but not which image to use.

    For now I’m back to using NextGen Gallery since it’s working fine, but I’d prefer to dump the plugin.

    As a side-note, I also had to correct the media files in the install for the extra commas to make the “add media” buttons work right.

    One more variation on the problem: Mine is auto-creating only the medium-sized image and not the thumbnail size, so when I tell the media tool to insert a thumbnail, it uses the full image and inserts code to display it small … which is a drag when you have a page with a lot of photos because it takes forever to load.

    I’m using ImageReady to create my photos (so they’re all RGB jpgs) and none is larger than around 70K, so they’re not choking the system.

    I don’t know much about forums; is this considered a bug that we submit a report on?

    Just want to check back in to say I figured out my problem. Nothing wrong with 2.5, but only with me!

    Yesterday I happened to be on the settings > miscellaneous page and found the problem. If the field next to thumbnail size is blank, it won’t create a thumbnail at all. I put numbers in there, and left the medium size blank since I never use it, and voila: works like a charm. Hope this helps someone else who didn’t get to that options page.

    @automaton : Thanks a lot! The image was in Greyscale and that was the source of the problem. This problem is still not fixed in the 2.6 version.

    I have the same problem, thumbnails are not generated. Instead a full resized photo is inserted.

    I have wordpress running locally at apache on fresh install ubuntu server.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WP 2.5 gallery won’t make some thumbnails’ is closed to new replies.