WP 2.5 blog admin error (6 posts)

  1. mlapage
    Posted 7 years ago #

    I go to //www.thehumanchronicle.com and go to Log In in sidebar, which goes to WP Admin Log In page. When I enter my user and password I get this error message (//www.thehumanchronicle.com/wp-admin/):

    Warning: main(/home/thehu22/public_html/wp-admin/includes/admin.php) [function.main]: failed to open stream: No such file or directory in /home/thehu22/public_html/wp-admin/admin.php on line 14

    Fatal error: main() [function.require]: Failed opening required '/home/thehu22/public_html/wp-admin/includes/admin.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/thehu22/public_html/wp-admin/admin.php on line 14

    The last time I logged into the blog admin area, I went to settings, noticed the URL and blog boxed settings were the same (/thehumanchronicle.com/thehuchron). I was having a problem with the '.com' URL appearing different than the 'Home' page, on the Internet browser. I had tried a change to the URL and blog boxed settings with no problem. However, when I deleted the '/thehuchron' part of the URL and blog boxed settings in the administration area, I got the '.com' URL and the 'Home' page to look the same, but could no longer login to the admin area (and got the error message).

    Problem #1 – I don’t understand what the error message is telling me! What is missing? and/or What I need to add? on line 14 of the admin.php.

    When I am on the blog site and ‘View Source’ for that page, I can see where to add ‘/thehuchron’. I have looked at the ‘admin.php’ file noted in the error message, but I don’t know what to add at/or on line 14!

    Is this what is to be added on line 14: include_path='.:/usr/lib/php:/usr/local/lib/php'?

    If I am to edit a directory or file, I need more specific information.


  2. MichaelH
    Posted 7 years ago #

    Consider using phpMyAdmin to make sure your wp_options table has the correct values in siteurl and home.

    siteurl is your WordPress address (URL) and home is your Blog Address (URL).

    See http://www.tamba2.org.uk/wordpress/site-url/

  3. mlapage
    Posted 7 years ago #

    Thanks for the information!! It was of great help. This did get me back into the blog Admin area. However!

    I am back to my original problem. When one goes to my blog site, the '.com' page and 'home' page are not the same. I went into the admin area and made a title change in the sidebar. When I logged out and did a refresh I found the 'Home' page (URL: //www.thehumanchronicle.com/thehuchron/) showed the title change, the '.com' page (URL: //www.thehumanchronicle.com/) did not.

    The problem may lie in the '.com' is in the ROOT dir and the 'Home' is in the /thehuchron dir? I have been through all the directories and files of the Root dir and have not found any reference to //www.thehumanchronicle.com/ page.

    Can you help me with this - point me in the correct direction?


  4. MichaelH
    Posted 7 years ago #

    It looks like your WordPress files are in web-root sub-folder, thehuchron.

    To make WordPress available at http://www.thehumanchronicle.com just change in Settings->General, the Blog address (URL) to http://www.thehumanchronicle.com and put this index.php file in your web-root folder (it is the same folder that contains the thehuchron folder)

    /* Short and sweet */
    define('WP_USE_THEMES', true);

    Then update your permalinks in Settings->Permalinks.

  5. mlapage
    Posted 7 years ago #


    Thanks, the index.php worked great. That was the only change I made. When one enters .thehumanchronicle.com in the browser, they get to the /thehuchron page (also the Home page). Will that be a problem if I don't use the other suggestions?

    Thanks again!!!

  6. MichaelH
    Posted 7 years ago #

    Will that be a problem if I don't use the other suggestions?

    That question confused me...

Topic Closed

This topic has been closed to new replies.

About this Topic