Support » Fixing WordPress » WP 2.1 – “you don’t have permission..”

  • Sorry guys I hate to bring this up again, but I’ve searched everywhere and nothing works.
    I’ve installed 2.1, and I’m unable to create categories or delete posts. I always get the famous “you don’t have permission to do that” error.
    I tried installing both through fantastico as well as manually, I’ve cleared cookies from both IE and Firefox, I’m sure I’m in the Admin account, and still nothing works.
    I should also mention my DB user has all required privileges.

    Thanks alot for taking the time to read my post 🙂

Viewing 15 replies - 1 through 15 (of 36 total)
  • Got any plugins running? Try disabling them.

    Nope, no plugins running.

    I’ve got the same problem. No plugins, cleared cookies, and I’m triple postive that I’m set as Administrator.

    Hope someone figures this out soon.

    I’m really running out of ideas here, which is too bad because I really wanted to us WP for my site

    This worked for all my problems with wordpress 2.1. Make another account with full site admin powers and take away admin from your old account and then give it back. Sounds stupid but it did the trick and everything seems to work fine now.

    Hi Bucker
    Thanks alot for the tip, but I tried that to no avail. This is quite odd, nothing seems to work. Could it be file permissions?

    Re-applying the adminstrator role to my admin user id solved my problems with adding categories and deleting posts.

    Hmm .. emvee’s suggestion seemed to work for me

    didnt work for me

    im so desperate i tried all the tricks to no success

    the only trick that worked is disabling javascript in firefox

    but as you all know i cant just disable it because some if not most of wordpress core files need javascript

    so now am terribly helpless!

    Oh re-applying permission is working! But it’s tricky. You should first set different role for your account then immediately (without logout or something) give you again administrator privilegies! Then I successfully added category!!!

    I tried this but it didnt work for me 🙁

    What is the exact error message that you are getting? I searched through the code, and there’s no such error as “you don’t have permission to do that”.

    I’ll throw in as well… also getting this error on a fresh install of 2.1 – no plugins, no cache, etc. I’ve tried re-asserting Admin rights, to no avail.

    @otto42
    Actually – there is such an error. It’s in the AJAX code, which can be found in /wp-includes/js/wp-ajax-js.php. It’s in the JS method WPAjax.parseAjaxResponse… forgive me if I’m off – my JS is a bit rusty.

    I don’t know the WP code at all, and my AJAX work is limited… but I’m looking for the code that actually handles the AJAX requests. It seems to be returning erroneous results, and denying permission when it shouldn’t.

    Any help would be great, as it appears I’m not the only one running into the problem.

    -sean

    I’m experiencing the same issue regarding adding categories.

    Huh. I wonder how I missed that one.

    Anyway, the code that actually handles the ajax requests is in wp-admin/admin-ajax.php.

    And I think there’s a bug there. It’s checking for the “delete_post” capability, but the name of that capability is actually “delete_posts”. Or not. I’m uncertain of that one.

Viewing 15 replies - 1 through 15 (of 36 total)
  • The topic ‘WP 2.1 – “you don’t have permission..”’ is closed to new replies.