Support » Fixing WordPress » WP 2.1 Insert/Edit image box won’t go away (firefox)

  • I’ve completed an upgrade from 206 to 2.1, and everything went just fine. I went to edit a post, and insert a new picture. Upload went fine, although I don’t like the new way images are presented because it defaults to link to the image, but oh well.

    So I insert the image, and then want to edit its properties to give it a title, and align it to the left, so I click the insert/edit image icon, and the box pops up. I set align to left, give it a title, and hit update, and nothing happens. Hit cancel, nothing happens. Hit the X in the corner, nothing happens. The whole browser window is stuck. I had to reload the page to clear it off.

    This is using Firefox browser. With the IE browser, the insert/edit box goes away when I’m done with it.

Viewing 10 replies - 1 through 10 (of 10 total)
  • I have the same problem. In fact, this is happening with the add/remove links and spell check features in the wysiwyg editor as well.

    The little windows are in fact balnk and they can not be closed. The browser needs to be shut down subsequent to this. [FireFox]


    Me too on both the links & the images. Restart the browser fixes it does it? Cool.

    A bug on WP or FF?

    Well, a restart doesn’t fix it for me.

    I posted 3 posts with images & links tonight fine. Subsequent posts won’t let me do it, a blank box just hangs around & won’t go away. I have to use the HTML editor to insert them.

    Nothing changed, so what happened?

    I still don’t know, but I went into Tools/Advanced in FF2.0.1 to the Javascript options and checked the box that allows javascript to ‘raise/lower’ windows.

    Fixed it for me.

    HTH someone out there….

    Did anyone find a fix for this problem….PLEASE? It happens to me in Firefox, IE and Safari… If I try to add an image and click on the icon… (tree) I get a blank box and the entire application freezes….

    Was this ever resolved for you? I get more or less the same thing. Blank box and can’t get rid of it. I played around with the Java settings in FF but no luck. It’s driving me crazy.


    I’m having the same problem…blank insert screen, follows the cursor, won’t go away.

    It must be a Firefox problem. I finally gave up and am now opening in FF but if I have to add links or images I use an add-on to open the page up in IE. There the boxes work.

    I tried creating a new profile in FF and that worked until I added my bookmarks back in and then I lost it again.




    For the record – I’ve suddenly run into this problem as well. The only thing I had changed recently was the inclusion of a social bookmarking add-on for FF.

    I deleted that, cleared the cache and rebooted for good measure. Nothing changed and like Tom I’m now having to use the editor within an IE tab.

    Looking at the FireFox error console it seems to be CSS commands called within TinyMCE that Firefox doesn’t like, but why it happened overnight like this I have no idea. It used to work just fine.

    I’d love to hear if anyone ever finds the solution.

    Is there an update to this? I tried tyrebagger’s suggestion but still see the error in FF on OS X.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘WP 2.1 Insert/Edit image box won’t go away (firefox)’ is closed to new replies.