Support » How-To and Troubleshooting » WP 2.0.4 – running terribly slowly!

WP 2.0.4 – running terribly slowly!

  • Hi, I don’t know if there’s any solution to this, but it’s worth a try.

    Last night I upgraded an intranet (hence can’t give URL, sorry) to the latest version of WP, v 2.0.4. I cut down on the plugins I’ve been using for the last three versions, but my site is now running like a snail on tranquilisers.

    I’ve dropped some redundant SQL database tables, I’ve optimised the SQL database, and I’ve disabled plugins which aren’t strictly necessary to the functioning of my site. I’m using a very plain theme with no graphics which I haven’t changed for a long time, so I doubt it’s that which is causing the problem. I’ve even installed a WP-Cache plugin, which seems to be helping a little, but not enough.

    I’m really loath to get rid of any plugins as I figure I really need the ones I’ve got – they’ve worked fine with all the older versions of WP I’ve used so far.

    Can anyone suggest anything else I can do to speed things up other than disabling plugins? I’d love to hear any ideas because this lag in speed is driving me nuts!

    Many thanks,
    Kind regards,

Viewing 15 replies - 16 through 30 (of 63 total)
  • Same here!! But I had this on v2.0.2 and v2.0.3 even with plugins deactivated!. I don’t think it’s the webhost!!! Loading the home page takes a good 30 seconds. As an example, Gallery2 runs superfast if I directly access it (almost instantly) but when I load it through WP (WPG2) it takes its own sweet time… definately a big issue!

    I know the problem is not with my host. Have the devs been able to make progess on tracking this one down? I’d sure like to know what’s going on.

    don (el paso)

    Has anyone else been able to comfirm this?

    don (el paso)

    It is helpful to the devs to know, if you are experiencing a slow-down after upgrading to 2.0.4, from which version you upgraded, as well as where the slow-down occurs.

    as i menstion above
    writing the post editing the saving the post when we refresh it slow almost every action seem slow

    Alright, since nobody here has yet provided enough insight into what might really be wrong, here’s a checklist of things that you can try to help diagnose the problem if you can, or in the mean time help alleviate the problem.

    If you’d like to help diagnose the problem, here’s a few things you can try. First thing we can try is dumping a list of SQL queries. To do so, edit your wp-config.php and add this line, preferably somewhere near the top, maybe even as the second line.

    define(’SAVEQUERIES’, true);

    Then, in the footer of your theme, add the line.

    <?php var_dump($wpdb->savedqueries); ?>

    You can add the results to a pastebin or post them here, doesn’t particularly matter to me. Might be easiest to view the results using View Source in your browser.

    If you feel a bit more experienced and up to a challenge, you can install xdebug2 for PHP ( http://xdebug.net ), and then use either KCacheGrind for linux or WinCacheGrind on windows and save some images of the calltrees which show where WordPress is running slow. A good tutorial is at http://xdebug.org/docs-profiling2.php .

    Lastly, to temporarily alleviate the problem until someone can track down the cause, the first thing you want to do is _not_ to downgrade. Try asking your host or installing APC yourself, which should boost performance considerably. Also check and see how your MySQL caching is performing, and maybe increase the amount of RAM you allow it to use. There are tons more things you could try, and I don’t feel like writing them all out here, but perhaps someone else can.

    I hate having to add my voice to this particular thread, but I’m also experiencing the slow-down.

    2.0.3 was absolutely fine. No problems at all during the upgrade to 2.0.4, no errors generated.

    Logging in is a nightmare at times. I’ve experienced delays of up to a minute before the admin panel appears. Since disabling display of the admin panel with all news stuff, things have improved marginally (only by a couple of seconds though) and in no way near enough to call it a real improvement.

    Posting results in long delays on occasion. What’s really frustrating is that it’s not an everytime occurance, so it’s really difficult to pin down at what stage the slow-down occurs.

    Similarly, editing posts results in the same delays. Again, not every time.

    Turning the cache on or off makes very little difference, although as Choopafrank says, there IS an impact on server load without it.

    I thought it was just me, so I’m pleased (not in a happy way though) to see I’m not the only one experiencing this. Hopefully someone really clever out there will come to our salvation.

    Moderator Mark Jaquith


    To anyone experiencing problems: be sure to turn off all your plugins and switch to the default theme, just to be sure it isn’t something there. Beyond that, dumps of your queries and a description of your hosting environment (OS, server, PHP version, mod_php/cgi/fastcgi etc) might help. It’s not a universal problem, so we have to figure out what it is about your specific setup that’s doing it.

    In the above code I posted for saving database queries, I have two corrections. One is, the define line should be this:

    define('SAVEQUERIES', true);

    And for your footer, the variable should be $wpdb->queries instead of $wpdb->savequeries.

    I just upgraded from 2.0.3 and 2.0.4, and am not (fingers crossed) experiencing any such problems.

    I’m no expert, but here’s an idea: how about getting rid of the pingback features? My site used to load fairly slow at times as well (with WP 1.5), but I’ve rarely experienced any such problems since getting rid of those pinback features.

    Another idea: if your host has some error log feature, go check the error log! It might clue you in to what’s going on. E.g., maybe WP is looking for a file that is not there.

    Yosemite, sorry to answer your question so late – been away for a few days.

    Yes, I did run upgrade.php, and everything went to plan. There doesn’t seem to be any one particular page which loads more slowly than others: every page loads slowly now since the upgrade, although some are worse than others. However, there is no consistency in which pages are worse.

    I don’t use pingback (as it’s an intranet), and I don’t have that many plugins in use. I’ve got a very basic theme, and even when I tried it with the default theme, that made no difference to the slow speed.

    Sorry to be so dim, but what exactly is an “SQL dump”? I know absolutely nothing about SQL or servers or whatever, so I’m a bit nervous of tinkering with things I don’t understand in case I break it well and truly!


    croila (and others): If you can, hang on… Dev’s are looking into this.

    thanks for the heads-up yosemite

    oh, in the meantime i added the savequeries dump to my footer, but i don’t know what i’m looking at, or should i say look for? am i looking for high numbers after float()?

    I have the same problem for a long time…
    I also have a php gallery on my website which runs just as slow as wp. Sometime it is ok, mostly during the night, which takes 1-4 seconds to load. In the afternoon, however, my wp could take up to 40 seconds for the actual page to appear – meaning it’s totally white and blank before the page appear. It loads fast after the page shows up though.
    Can someone tell me if it is the same problem with you.
    I suspect it’s the server problem. I use globat with the most basic, cheapest plan.

Viewing 15 replies - 16 through 30 (of 63 total)
  • The topic ‘WP 2.0.4 – running terribly slowly!’ is closed to new replies.