Support » How-To and Troubleshooting » [Resolved] WP 2.0 messed up my permalinks

[Resolved] WP 2.0 messed up my permalinks

  • Hi!

    Today I upgraded 1.5.2 to 2.0. After the upgrade my permalinks are not working at all. I get WP generated 404’s on all pages. Once I set the permalink options to “Default” everything works fine again.

    After entering the permalink structure I used before the update (/%year%-%monthnum%/%postname%/) and pressing update I get 404’s. I tried deleting the .htaccess (which I didn’t keep from the 1.5.2 install, it must have been generated by 2.0), setting the permalink options to “Default” again and updating. After that I switched to “Custom” (/%year%-%monthnum%/%postname%/) again and updated to let WP write another .htaccess. This .htaccess reads:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php

    # END WordPress

    http://www.almehag.se/tmp/dump_env.html shows the base page generated by Dump Enviroment 1.0.1 (check the source) with the permalink structure I want to use enabled (/%year%-%monthnum%/%postname%/) if that helps anyone.

    Upping the old .htaccess I used for 1.5.2 again doesn’t work either. You can check out my old htaccess here: http://www.almehag.se/tmp/htaccess.txt . It is for some reason substantially bigger than the new one that WP2 has generated.

    My blog is here (I’ve changed the permalinks to “Default” for now as nothing else works): http://blog.almehag.se/

    Any help appreciated, I’m quite frustrated.

    Thanks in advance…

Viewing 15 replies - 16 through 30 (of 52 total)
  • Either I’m crazy or the links to classes/functions-post up there just aren’t working. Mighty peculiar, and my blog is now dead in the water. I hope a fix comes in soon!

    hello everybody davide mellis – http://dam.mellis.org/ – gave me the solution to my problems.

    select customize permalink structure and copy this:


    it works and it’s great!!

    If the solution is there at dam.mellis.org I sure couldn’t find it.

    Well, the solution rogopag posted is the same one that’s all over the place – whether dam.mellis.org or whatever….

    It’s nothing more than the default structure with /index.php/ prepended – which doesn’t always work either.

    O.k., folks. My problem is sort of the same thing, but different. I’m able to change my permalinks to Numeric without any 404 error messages, but I lose my header image. The img src code still appears in the file, it just doesn’t display. Any help would be greatly appreciated. Thanks.


    I can see it, if you mean the “barcode”-like jpg.

    Right. It works on the front page only. However, if you click around, that barcode jpg disappears. I just adjusted the permalinks again so that you folks can observe the problem. Thanks for taking a look.


    Don’t use relative path – it doesn’t work with permalinks:
    on your main page
    the path to the image is /images/yourpic.jpg.
    so putting together it gives

    But when you go the the single post view:
    the path will become:
    http://indieretailer.com/archives/13/images/yourpic.jpg which obviously doesn’t work.

    o.k., thank you for the diagnosis. Forgive my ignorance, but how about a cure?


    Ummm… I think I got it. I’m not sure this is the best solution, but it certainly works. I changed the path in the header from img src=”images/picture.jpg” to img src=”http://www.indieretailer.com/images/picture.jpg”

    Thank you for the help.


    I had a similar problem and went through every step located in this guide but nothing worked until I started disabling all of my plugins and found that the nice archive plugin was causing the inability to change pages. Try disabling it (if it’s active and you have it) and see if it fixes your problem.

    From the posts witten by Ryan, I understand that to fix this problem (that I’m suffering in http://sachiel.homelinux.net), I only have to replace my classes.php and functions-post.php for the versions he offers.

    I have tryed it, but the the web looks completely different, like printing the contents of these files. Am I missing something?

    I’m having similar problems. I’ve made two posts using the default permalink structure, I then tried to change to a custom structure and I get 404s when clicking on the post titles. I’ve tried some of the suggestions posted here, but no luck.

    I am also having the 404 problem with a fresh install of WP 2.0 (not an upgrade). The 404s are Apache. I have installed Ryan’s patched files above (both versions) and only works on default or with index.php prepended.

    Does anyone have a fix for this?



    are the fixes that ryan posted included on the 2.0 build that you download from wordpress.org?

Viewing 15 replies - 16 through 30 (of 52 total)
  • The topic ‘[Resolved] WP 2.0 messed up my permalinks’ is closed to new replies.