WordPress.org

Support

Support » How-To and Troubleshooting » WP 2.0 — How can I stop / disable RSS-Feeds ?

WP 2.0 — How can I stop / disable RSS-Feeds ?

Viewing 12 replies - 1 through 12 (of 12 total)
  • What RSS feeds do you want to stop or disable?

    Sounds like he wants to stop all of them.

    All of what? Outgoing RSS Feeds? Incoming RSS Feeds on the admin page? His question is ambiguous.

    Hello,

    I want to stop / disable outgoing RSS Feeds.
    Reason:
    In the past the search engines noticed my HTML-pages (good).
    But a week ago Google began to notice my RSS-Feeds instead of my HTML-pages (bad).

    Josef

    Just disable the line for the rss feeds in you header.php file in your template. Easy, really

    How exactly? I mean, which part of the header.php needs to be removed?

    Some people wish to disable RSS for semi-private blogs, such as your daily thoughts, or a journal of an illness. Of course nothing on the internet is totally private, but if one wishes to do this, then removing RSS and pings would be one of the first steps:
    –Remove ping-o-matic and anything from the Pings list in the admin > options
    –It is possible to completely delete some of the PHP files in your wordpress root (the ones dealing with feeds only), unfortunately I don’t have a list of safe files to delete, but this would be a handy list if anyone knows.

    That said — However, there could be a better way for Josef, if you only want to get Google to prioritize your homepage and not your feedpage. Perhaps you should try the Sitemaps plugin which creates a Google Sitemap, to guide the bot in order of importance.

    How exactly? I mean, which part of the header.php needs to be removed?

    Look for this line in header.php:
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />

    and remove it.

    Thank you!

    will it work to just comment out that line, or should it be completely deleted??

    That’s really just a link to the rss feed. It doesn’t remove the rss feed.

    I just tried something. I went into the admin area, under Options > Reading, and I set the number of posts for rss to 0. When I tried to view the feed, I got a 404. So that’s what I would recommend someone do when they want to disable their outgoing rss feeds.

    If you want to see the result right away, you may need to delete the files in wp-content/cache

    When I set my posts for RSS to 0, it resets it to 1 after I save changes.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘WP 2.0 — How can I stop / disable RSS-Feeds ?’ is closed to new replies.
Skip to toolbar