WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] WP 2.0 broke after database backup

[Resolved] WP 2.0 broke after database backup

  • Hi all, here is what happened:

    First thing I saw was that in admin presentation, instead of showing a screenshot or theme name for my current custom theme, it would display the whole style.css file content for that theme.

    So I decided to do a db backup. Used the plugin. It said that wp-content was not writable. So I chmoded it 666 and reran db backup (default plugin with 2.0).

    Then:

    1/my front index page was blank (no html inside), but no error code
    2/I could still access admin panel although: a/no themes would show under Presentation, and b/no plugins would show under Plugins; i.e. I could access the page, but the list would be blank, as if no themes/plugins would be uploaded.

    I checked permissions that looked ok. I checked dir structure that looked ok too.

    On the irc channel someone suggested that I drop the option table in phpMyAdmin and rerun install.php. install.php said that wp was already installed and that I need to drop the whole db.

    Then I did a fresh install on a separate dir. Uploaded my custom theme and it still shows the css file content (instead of screenshot or theme name).

    Here are my questions (besides any hint would be appreciated): if my theme is broken how can I fix it (what does the fact that style.css gets displayed would indicate)? Is there a way I can repair my old install (given that I would reimport the option table)?
    What could the backup plugin have broken? Is it a db problem?

    I saw this on the forums: http://wordpress.org/support/topic/41058?replies=13 but if I could avoid a whle reinstall… and my index page is blank whereas theirs would diplay fine.

    I’m using 2.0 with scp_flex customized theme + ultimate tag warrior, flickr post bar, flickr album, sem-recent posts, recent sem-comments plugins.

    Many thanks in advance.

Viewing 3 replies - 1 through 3 (of 3 total)
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] WP 2.0 broke after database backup’ is closed to new replies.