Support » Fixing WordPress » WP 1.5.1.2 -> Running PHP in pages

Viewing 8 replies - 1 through 8 (of 8 total)
  • Try RunPHP – I’m using it with no problem.

    Thanks I will try that :0)

    Okay, I uploaded it, activated it, and unchecked ” Options -> Writing, turn off the “WordPress should correct invalidly nested XHTML automaticallyâ€? option.” what am I missing?

    skippy

    (@skippy)

    Member

    When writing a post or page, are you checking the “eval() Content” option at the top-middle of the Advanced screen?

    Actually, you don’t have to make php run on pages if you wan to use the smart archives. you can create a new file, say archives.php in your theme folder. use this code:
    /*
    Template Name: Smart Archives
    */
    <?php get_header()?>

    <?php smartArchives() ?>

    <?php get_sidebar() ?>
    <?php get_footer() ?>

    **Remember, the Template Name is required

    Then, create a new page (in your WP admin panel), and at the bottom (advance editing), you can choose which template to use, either default template or smart archives. Choose smart archives. Save the page.

    All done 😀

    skippy

    (@skippy)

    Member

    See here for an expanded tutorial on this subject.

    Oh, now I understand what “eval() Content” thing is all about – I didn’t know what it was until you said “check it”. Have clicked it, and it works great now. Cheers very much.

    I could sure use some help on the RunPHP plugin.

    I installed, turned off the xhtml box, checked eval()php, am using [ instead of < , but cannot get it to work. I am using it in pages. Does that make difference?

    Thanks in advance for any help…
    Kathy

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘WP 1.5.1.2 -> Running PHP in pages’ is closed to new replies.