WP 1 RC1 -> WP-login Error (9 posts)

  1. antifuse
    Posted 12 years ago #

    I found myself getting fun errors like that whenever I have extraneous blank lines at the end of my php files. Sounds dumb, but it's something to check anyway.

  2. WildDuck
    Posted 12 years ago #

    I still get the same error even with a clean install with the new platinum version....hmmm...strange.
    Tested with the old 0.72 and its working fine...

  3. webguynj
    Posted 12 years ago #

    I am getting identical problems on a totally clean install either via Frontpage or using FTP. I used the Platinum build as well.

  4. WildDuck
    Posted 12 years ago #

    Hi allusion
    Yes and tested it in IE, Opera (new clean install), and firebird...
    everything failed.
    I edited this part of the code in wp-login back to the old b2loging version but it didnt worked either.
    New wp-login code:
    setcookie('wordpressuser_'.$cookiehash, $user_login, time()+31536000);
    if ($pass_is_md5) {
    setcookie('wordpresspass_'.$cookiehash, $user_pass, time()+31536000);
    } else {
    setcookie('wordpresspass_'.$cookiehash, md5($user_pass), time()+31536000);
    if (empty($HTTP_COOKIE_VARS['wordpressblogid_'.$cookiehash])) {
    setcookie('wordpressblogid_'.$cookiehash, 1,time()+31536000);
    It was the CVS update between christmas and new year all the trubles started til then everthing worked fine :-)

  5. webguynj
    Posted 12 years ago #

    This is on a brand new site that has never been live before. Its a new domain name too so there shouldn't be any cookies to clear for the site and I have gotten the error on two computers

  6. Alex King
    Posted 12 years ago #

    Comment out that line in get_settings() - don't have it echo anything. The echo (outputting data to the page) is what is breaking it.

  7. Jaykul
    Posted 12 years ago #

    Well, you can either fix the problem by going into your database and adding that record (I'm not 100% sure what goes in there) or you can fix the symptom by commenting out the echo now that you know you have the same problem I did, just commenting it out will work for now.
    Long term, you have to fix the missing setting, i think...

  8. Matt Mullenweg
    Posted 12 years ago #

    The setting should be removed, so long term, you can remove the line from wp-settings.php.

  9. webguynj
    Posted 12 years ago #

    Well adding the comment_allowed_tags entry definitely solved the header problems. The question is what does this entry do? and Why did they change the default behaviour of some inherent functions without thorough testing and veryfying that the default populated database worked?

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.