WordPress.org

Support

Support » Plugins and Hacks » [Resolved] WowSlider causing Jquery Error after WP 3.5.1 update

[Resolved] WowSlider causing Jquery Error after WP 3.5.1 update

  • After updating WP to 3.5.1, I’ve found that WowSlider is throwing a JS error. I think I found the issue, and it seems to be deprecated JS code. Here’s the code:

    if ((D.browser.msie && parseInt(D.browser.version, 10) < 8) || (/Safari/.test(t))) {
            var P = Math.pow(10, Math.ceil(Math.LOG10E * Math.log(B)));
            I.css({
                width: P + "00%"
            });
            i.css({
                width: 100 / P + "%"
            })
        } else {
            I.css({
                width: B + "00%",
                display: "table"
            });
            i.css({
                display: "table-cell",
                "float": "none",
                width: "auto"
            })
        }

    The deprecated code seems to be right at the top, D.browser.msie.
    For now, I’ve just commented out the whole block, and WowSlider is working again, and not throwing an error. Just a temp fix though. I’ve tried a few googles & code changes, but with no luck so far. I’ve also updated my WowSlider slider creator to v2.8, but it’s still generating the same JS. SO, the answer seems to know the right code. Assuming I am correct, anyone know the correct code, so what I think is a MS IE fix, works again?
    Cheers, Kevin Logan

    http://wordpress.org/extend/plugins/wowslider/

Viewing 8 replies - 1 through 8 (of 8 total)
Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Resolved] WowSlider causing Jquery Error after WP 3.5.1 update’ is closed to new replies.