Support » Plugins and Hacks » [Resolved] WowSlider 2.6 not working with WordPress 3.5

[Resolved] WowSlider 2.6 not working with WordPress 3.5

  • i sent this in email form to support, but am posting here as well in case that inbox is busy with other customers.

    I have successfully used the WowSlider for my company’s WordPress page for the past month or so, and the plugin now seems broken, as I get this message when clicking on the plug-in page:

    “Warning: Missing argument 1 for WOWSlider_List_Table::bulk_actions(), called in /home/transigm/public_html/new-site/transigmapartners/wp-admin/includes/class-wp-list-table.php on line 768 and defined in /home/transigm/public_html/new-site/transigmapartners/wp-content/plugins/wowslider/list-table.php on line 119”

    Can you please tell me what this means?

    Whenever I try to load a slider I now get the message: “Wrong Slider.”

    I updated both WordPress and WowSlider today, so an now operating on WordPress 3.5 and WowSlider 2.6. Here is my website, with the slider currently gone:


    I tried the upload via folder option and that gives me the same exact error message. I tried re-installing and this did not work.

    Thank you,


Viewing 15 replies - 16 through 30 (of 41 total)
  • What error codes do you guys get in Firebug when you click on ‘console’?
    Mine is jquery line 2 error.

    I started from scratch on everything. I can watch the slider where it has been downloaded in wordpress.

    Just doesn’t show up in the post … at least in the preview mode. I don’t want to publish it because the mistake will go to all the subscribers.

    Don’t want that.



    Just wondering if we are we going to get a fix for this plug-in? I have seen and installed several updates but it still doesn’t work.

    I know. I like the plugin greatly. I hope they get it fixed. I can load it into the sliders file in wordpress, can actually watch it work, but it just shows a blank on my 20-10 them when I post it.

    I have a slider ready to go but I can’t use it. Have loaded updates but still no go.

    I hope it works out.



    Plugin Author WOWSlider.com


    If you see WOWSlider shortcode or empty space instead of slideshow:

    1) Make sure that you add a shortcode at “HTML” tab, not at “Visual” tab.
    2) Shortcode will work with pages and posts only. If you use widget or template you need WOWSlider PHP code.
    3) If problem will persist, possibly WOWSlider has a conflict with your theme or plugin. You can try to use default theme and temporary disable plugins.
    Also, you can insert WOWSlider manually.
    Instruction here

    Plugin Author WOWSlider.com



    I have just checked your page:

    and found the reason of problem. It’s “Rotate” effect. Unfortunately, this effect doesn’t work in WordPress. Sorry for inconvenience. Our developers will fix this problem in the next version. Now you can use any other effect or add WOWSlider with “Rotate” effect manually:
    Instruction here
    Also, I found the you use 17 jquery on your page. It should be only 1 jquery per page. Also, some of these jquery were added by plugins that I couldn’t find on your page… For example: “fluid-width-video-wrapper”, “Easy element scrolling”, “flexslider”… It’s good idea to disable plugins that you don’t use on your page. Additional scripts increase loading speed of your page and can conflict with plugins that you really use.

    Thank You! It does work again when I choose an effect other than rotate…that one is my favorite for my type of website.

    I disabled a few plugins I was not using. But it seems the Theme developer has the 3 you mentioned built into the pages even though on used on home page or portfolio page.
    I don’t know how to disable them on the other pages where they are not used 🙁

    Thanks again for your time and input and looking forward to the next update with ‘rotate’ in the slider (it did work on WP 3.4.2).

    PS. The Manually installing Wowslider on webpage can be done for a WP page??
    I know how on an html website using my Dreamweaver, but not figured it out using WP.


    Plugin Author WOWSlider.com


    It’s possible to insert WOWSlider manually. “Rotate” effect will work in this case.

    1) Create your slideshow using WOWSlider.
    2) Publish it on a local drive in any test folder:

    – open Gallery->Properties->Publish or click ‘Publish’ button on the main menu panel;
    – select ‘Publish to folder’, click ‘Browse’ button and select any local folder;
    – click ‘Publish’ button

    3) Open index.html file from the saved folder in any text editor (Notepad for example) or you can:
    – open index.html page in any browser
    – right click on the page
    – select view source of the page.

    You’ll find ‘engine’ and ‘data’ folders in this saved folder also.

    4) Copy code for HEAD and BODY sections of WOWSlider, go to HTML (text) tab in WordPress and paste WOWSlider sections in the place where you want to have a slider, for example:

    <!-- Start WOWSlider.com HEAD section -->
    <link rel="stylesheet" type="text/css" href="engine1/style.css" media="screen" />
    <style type="text/css">a#vlb{display:none}</style>
    <script type="text/javascript" src="engine1/jquery.js"></script>
    <!-- End WOWSlider.com HEAD section -->
    <!-- Start WOWSlider.com BODY section -->
    <!-- End WOWSlider.com BODY section -->

    5) Notice, you should copy ‘data’ folder with images and ‘engine’ folder with all files into the same folder with your own webpage.

    6) Preview your website in the browser.

    That’s all.

    Thanks again. What you explained above is better than regular instruction for manually inserting (go to HTML (text) tab in WordPress and paste WOWSlider sections in the place where you want to have a slider, for example:).

    Only question ( I do hope so and you have been helpful ), is step # 5 above.
    Where in WP would I put those 2 folders? I have a theme, so in inside that folders root?

    Thanks again and sure others are enjoying your help!!

    Plugin Author WOWSlider.com


    If you plan to use default paths generated with WOWSlider, “data” and “engine” folders should be in the root folder, i.e. into the same folder with “wp-content”, “wp-includes” folders.
    Actually, you can store “data” and “engine” folders into any other place you like and edit paths to WOWSlider files in HTML code. For example, if you’ll place “data” and “engine” folders into “wp-content” folder, paths in HTML code should be:

    <!-- Start WOWSlider.com HEAD section -->
    <link rel="stylesheet" type="text/css" href="wp-content/engine1/style.css" media="screen" />
    <style type="text/css">a#vlb{display:none}</style>
    <script type="text/javascript" src="wp-content/engine1/jquery.js"></script>
    <!-- End WOWSlider.com HEAD section -->

    Well, I tested adding manually to a draft page and IT WORKED.
    You made it really simple the way you explained above!!

    Thanks again. Still building website and will incorporate later! Thanks!

    Plugin Author WOWSlider.com


    You’re welcome.

    I’m having issues uploading my slides. The uploader that comes with the plugin isn’t working. How can I upload these files manually?

    Plugin Author WOWSlider.com


    You can upload WOWSlider files in the same way as you upload any other files: images, video, etc.

Viewing 15 replies - 16 through 30 (of 41 total)
  • The topic ‘[Resolved] WowSlider 2.6 not working with WordPress 3.5’ is closed to new replies.