Support » Plugins and Hacks » [Resolved] Worst Support I Ever Got – Can someone else help?

[Resolved] Worst Support I Ever Got – Can someone else help?

  • I bought the unlimited website license, but I couldn’t get Wowslider to work with WordPress. I made a video (mp4) of what I was doing, so that I could get some help from support. I started sending emails saying I needed some help.

    1. They told me to give up on using it with WordPress, and just use it for static HTML pages.
    2. They told me to use the latest version of the program and the plugin (which I was already doing, and they could have seen what version I was using by watching the video I made for them).
    3. They never did watch the video. That would have taken three minutes of their precious time to help a customer. But without watching the video, they told me to “clarify” what the problem was — five days after I sent them a link to the video.
    4. Finally, they issued a refund without my consent. BUT THEY NEVER DID WATCH THE VIDEO OR GIVE ME ANY SUPPORT AS TO WHAT I AM DOING WRONG. Even after giving me a refund, my last email from them just said:

      “You can see on our demos that WOWSlider works with WordPress. So, problem not with our application, problem is on your side.
      Also you could try free version of WOWslider before purchase it.”

      But of course, I DID try the free version first. Duh.

    I’ve never had such bad support in all my years online.

    If anyone who’s NOT connected with the Worst Support Team on the Planet can watch that short video and suggest what I’m doing wrong and what I can do to make my Wowslider work, I would deeply appreciate it.


Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author WOWSlider.com


    2. They told me to use the latest version of the program and the plugin (which I was already doing, and they could have seen what version I was using by watching the video I made for them).

    Actually, it’s a correct instruction. But you didn’t do it. As I can see on your video, you use plugin v.2.5, but you were told to use THE LATEST VERSION OF PLUGIN 2.7. So, you should download the latest version of plugin here:
    install and activate it. After that you should add modules generated with WOWSlider using WOWSlider -> Add new menu in WordPress.

    Actually, I’ve tried that many times. I did do that.

    The reason the plugin is v.2.5 is because the full program, v.2.7.1, creates a plugin that is v.2.5.

    If you want the plugin to be v.2.7, you have to update it AFTER the full program creates a v.2.5 plugin. And even if you do that, IT WILL NOT INSTALL A SLIDER.

    Here, I made a second video, where you can see the plugin is v.2.7:


    But get back to me. I’m willing to work on this as long as it takes, now that I seem to have your attention.

    Plugin Author WOWSlider.com


    Again the same problem. You install PLUGIN V.2.5:
    Please see screenshot
    IT’S INCORRECTLY. You should deactivate and uninstall WOWSlider plugin. Then download the latest version from WordPress site, install and activate it. You’ll be able to add modules generated with desktop software after that only.
    This problem appears after WordPress was updated to v.3.5. We didn’t release new versions since. That’s why application generates modules with old version of plugin. It’ll be fixed in the next version.
    I made video too. Please see:
    Video here
    As you can see your module was successfully added.

    First, I would like to point out that your support team sent me 5 emails, starting Dec. 18, and nobody ever looked at that video I made, or made any helpful suggestions, until I started complaining here. I had to go public with it in order to get any help at all. But I’m glad somebody’s finally paying attention.

    Second, I tried what your video showed. I made a new video following your exact instructions. It did not work.

    Please watch this video. http://www.rhodagalaxy.com/wowslider3.mp4

    Very different results, though I did exactly what you did.

    Plugin Author WOWSlider.com


    Unfortunately, this link doesn’t work. I get 404 error message.

    I love how this topic is marked [resolved] when nothing at all has been resolved.

    OK, it’s there now. Please try this link.

    Plugin Author WOWSlider.com


    It seems that you have not enough access rights and WOWSlider couldn’t add its files on your server. Please check that you have chmod 777 for this folder “wp-content/uploads/wow-slider-plugin/”. Also, if you have not folder “wow-slider-plugin”, you should create it.
    Please see more info about changing of chmod here:
    How to change chmod

    I added the directory and set the permissions correctly as you described, but it still didn’t work.

    You can see what happened here: http://www.rhodagalaxy.com/wowslider4.mp4

    Also, was the plugin supposed to upload anything to that “wow-slider-plugin” directory? Because it’s still empty.

    The parent directory “wp-content/uploads” is also chmod 777.

    Once again, this developer seems to have just wandered off without reading my last post or resolving the problem at all.

    Plugin Author WOWSlider.com


    Try to do the following:
    1) Deactivate and delete WOWSlider plugin
    2) Download a new version 2.7.1 from here:
    3) Install and activate it.
    4) You should set chmod 777 for the following folders:
    * /wp-content/plugins/wowslider/import/
    * /wp-content/uploads/
    * /wp-content/uploads/wow-slider-plugin/
    5) IMPORTANT! Add sliders generated with WOWSlider using WOWSlider -> Add new, NOT Plugins->Add new.

    PS. It’s not good idea to speak to rudely, if you’re looking for some help.

    Moderator Jan Dembowski


    PS. It’s not good idea to speak to rudely, if you’re looking for some help.

    I’ll second that.

    @wlbryan Please watch your attitude, you’re not helping yourself here with that snark.

    Plugin Author WOWSlider.com


    We have New Year breaks. Office will be opened at 8 of January.

    Jan, I’ve been trying to get them to help me since Dec. 18, ten days ago. They’ve sent me an unending stream of emails, and now posts to this thread, and they refunded my money without my consent, but they still have not provided any support worthy of the name. I’ve been a customer support manager myself for a small company, and I’ve been appalled at the so-called “support” I’ve been given so far.

    I’ve been making videos with CamStudio to show them exactly what is going on. After 10 emails over the course of five days, nobody watched that first video until I made my complaint public on the WordPress forums here. On Wednesday, I made 3 more videos, in response to their “support”. But after I made the last one, they simply disappeared for another two days.

    I didn’t want a refund. I wanted help making their product work in WordPress. If I could simply get it to work, I’d be more than happy to pay their price for the plugin.

    In all honesty, Jan, I’ve never had such terrible support for any computer-related product or service in all my years. It’s been like pulling teeth to get any useful suggestions. At first, their advice to me – repeated twice in emails – was “Don’t use our WordPress plugin with WordPress; just use it with non-WordPress websites.” Is that the kind of support you encourage for WordPress plugins?

    And now you can see, they’re not providing any additional support until Jan. 8, which is 11 days from now. I’ll try the new suggestion they’ve offered, but if that doesn’t work it will be 21 days total since I first started asking for support, without their product working at all in WordPress for that period of time.

    I’m generally a very nice guy. My first few emails to them were pleasant requests for some assistance. But ten days later, my plugin is still useless. It’s been very, very frustrating.

    Moderator Jan Dembowski


    I’m generally a very nice guy.

    I get that, honestly I do. 🙂

    But here’s the thing and there’s been a whole sidebar discussion about this: this forum is not for commercially supported software. Yet that plugin is GPL’ed and hosted here so it’s odd.

    That is a plugin that is hosted here but plugin authors are absolutely under no obligation to support their code here. Or at all for that matter but it’s nice when they do.

    This was a sticky one because you did pay them. I’m of the opinion that paid customers should have their own forum on the vendor’s site and not here.

    It’s always tempting to vent in a public forum but we really discourage that here because it’s never a productive thing to do. It just doesn’t work. You wouldn’t do something just because I complained outloud about it to you, would you?

    they refunded my money without my consent

    That’s their option to do and they’re no longer bound or obligated to support you anymore.

    My advice to you is to leave this plugin behind, enjoy the New Year and look elsewhere for another plugin. That’s got to be more productive then this and I think you’ll be better off that way.

    Even if there isn’t a plugin that does quite what you want to do this one obviously isn’t working for you and it’s time to step away from it.

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] Worst Support I Ever Got – Can someone else help?’ is closed to new replies.