Support » Localhost Installs » worpress insists to install after reinstallation of MySQL

  • I made some mistakes with the admin of my database and didn’t find any other solution than to reinstall the complete WAMP-server.

    That of course rendered in a new MySQL-db but the old one was left so I could copy over my old WP-databases.

    But when I tried to open my old wp-project i started with the installation page.

    I have done a lot adding features (WP-ZOOM) and theme “Meeta” and is afraid that something will be destroyed if I continue to reinstall the wp-project.

    I have recently updated wp to 3.8.1 so it’s up-to-date.

    Can anyone give me an advice and/or what causes this problem and if I can deal with it in a proper way?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi Larand?

    Please Clerify.

    From your querry you had your old WAMP-served backed up?

    Then you deleted everything and started afresh?

    Hi Kelly,
    Well, when I decided to reinstall the WAMP, I took a copy of the complete data-directory. After the reinstallation I just copied the directory that hold one of my wp-databases and tried to get that to work.
    Then when I tried to open this “blog” I got the installation-page of WordPress.

    That was the situation when I started this post.
    After that I decided to try to follow the installation instructions but it did not work. The installation program told me that there was already a user registrated so I could not fill in the user name which was required. Moment 22 😉
    Ok I found that it could see the user table but could not retrieve a username.
    Checked the database, looked ok, alln tables where there but when I tried to read the content of the tables phpmyadmin told me that the tables didn’t exist. Strange but the truth is that it’s not enough copying that single directory, you need to copy more files and to be sure I copied the complete data-directory back again.

    After that I could open the “blog” but I could not see any post neither any pages. It tells that the page/post doesn’t exist but it does!
    If I create a new post or page I could see them using the preview but when I update the post/page it can not be seen any more.

    When I open the admin panel I can see and edit all posts and pages but they are not visible at the site. Only the first static page is visible along with the menus.

    Ok, the question has changed… How can I make WP to find my posts and pages?

    What I have done is:
    1. Removed all user records for root-user in the DB
    2. Re-entered root@localhost user — didn’t work well
    3. Took a copy of the complete data-directory
    4. Installed a new version of WAMP
    5. Copied the old data directory to mysql:s data-dir.
    6. Tried to start my blog.

    I’m using permalinks like “http://localhost/tradeblogg/2014/01/28/exempel-inlagg/”
    but I don’t know if that has something to do with it.

    Would be nice if you or someone else could find at least a clue of how to proceed with this… eeh.. disaster.

    I can also add that as I copied data from old MySQL database I also added the db-file that contain my bad root-user so I can not alter the database.

    See here:


    SQL query: Edit Edit

    GRANT ALL PRIVILEGES ON testwp . * TO ‘dbuser’@’localhost’ WITH GRANT OPTION ;

    MySQL said: Documentation
    #1044 – Access denied for user ‘root’@’localhost’ to database ‘testwp’

    I have to correct this too … which was the beginning of this story.. sigh….

    Ok, Now I restored the data-directory as the original and created my blog-database using mysql. Then I restored the database from an old backup and the database works as it should but the posts still gives 404.

    I changed permalinks to not be used and then everything just worked fine.

    I created a new blog and a new database but still permalinks doesn’t work.

    Is there a bug in the new wp3.8.1?
    I want to use permalinks so this is still an issue for me.

    My WordPress was running successfully until i reinstalled the WAMP server on my local machine.(due to some reason the WAMP got unistalled automatically and I had to reinstall it.) And the index.php file got overwritten with a new one.
    Now I can access myphpadmin but when trying to access WordPress getting the installation screen. When I put the site title and email id to install it again, it says ‘Please provide a valid username’ and in the username field it says ‘User(s) already exists’
    Please help me as I am new to WAMP and WordPress.

    This is been resolved after i created new database in phpmyadmin. and updated the database name in config.php

    I am getting that same message, however the database is gone from phpMyAdmin. The database files are on my harddrive, but I cannot get phpMyAdmin to see them.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘worpress insists to install after reinstallation of MySQL’ is closed to new replies.