WordPress.org

Forums

Worpdress , Varnish and connection reset by peer (9 posts)

  1. jeffqc
    Member
    Posted 3 years ago #

    I've an issue with process between worpdress my server and varnish.

    i publish, i get a reset by peer error, the site crash (offline) for a few minute, the site came back and the post appear on my site (during the crash the post is not process and is not inside all post section, it's kinda in between two world (i dont know better word to explain that issue ).

    http://www.tvqc.com/

    Thème blognews with 19 widgets

    plugin activated
    AddQuicktag
    Clean Archives Reloaded
    akimet
    coontact form 7
    Disable Autosave
    Google News XML Sitemap Generator
    Google XML Sitemap for images
    Google XML Sitemaps
    Just Another Author Widge
    Morfeo video gallery
    My Videotag
    Native RSS
    No 404 Errors
    Polldaddy Polls & Ratings
    Related Posts Thumbnails
    Sharedaddy
    Smart Youtube PRO
    Social Metric
    TimThumb Vulnerability Scanner
    Top 10
    Use Google Libraries
    WordPress SEO
    WP-Optimize
    WP Super Cache
    WP Widget Cache

    [ please do not bump ]

  2. Pothi
    Member
    Posted 3 years ago #

    I subscribed to this topic when I saw it about an hour back. So, when I received an email that someone replied to this thread, I was curious to know, if there is any solution or any way to troubleshoot it so that I learn from it. I'm disappointed to know that it was just bumped. :( There may be others subscribed to this topic too. So, no bumping, please!

    I wish I could delete my reply and yours to get it notified by others.

    BTW, you have not mentioned what stack you use (Varnish -> Nginx -> php-fpm? or Varnish -> Apache?). You have not mentioned, if there are any errors in the WordPress log or in the server log of Nginx, php-fpm or Apache (depending on what you deployed). You have not mentioned if there is any similarity between the default TTL in Varnish and the time for the site to come back online. Without any one of these, someone is unlikely to help (unless they already went through this issue and fixed it). Also, if your server uses Varnish cPanel plugin, try disabling the plugin to check, if it is related to Varnish.

  3. jeffqc
    Member
    Posted 3 years ago #

    thi is the page i get each time i post
    http://i.imgur.com/GZPX9.png

    The the site crash , go offline for like 2-3 minutes, then the post appear on my site a few minutes later..
    http://www.tvqc.com/2012/07/merlin-saison-5-un-game-of-thrones-joint-la-serie/

    The wole process tok like 5 minutes.

    Im waiting response form my host, on you technical question. My server is managed, so i dont know exactly whats varnish config they use.

  4. jeffqc
    Member
    Posted 3 years ago #

    here is a Mysql log
    Id | User | Host | db | Command | Time | State | Info
    | 201358 | xxxx_wrdp10 | localhost | xxxx_wrdp10 | Query | 406 | Copying to tmp table | SELECT SQL_CALC_FOUND_ROWS wp_posts.ID FROM wp_posts INNER JOIN wp_postmeta ON (wp_posts.ID = wp_p |
    | 201391 | xxx_wrdp10 | localhost | xxx_wrdp10 | Query | 402 | Copying to tmp table | SELECT SQL_CALC_FOUND_ROWS wp_posts.ID FROM wp_posts INNER JOIN wp_postmeta ON (wp_posts.ID = wp_p |
    | 201420 | xxxxx_wrdp10 | localhost | xxxxxx_wrdp10 | Query | 397 |

    and the list goes on.

  5. jeffqc
    Member
    Posted 3 years ago #

    here is my wp debug log

    http://www.tvqc.com/debug.log

    Warning 4.5 mb file

  6. jeffqc
    Member
    Posted 3 years ago #

    when im trying to acces the new post editor using Chrome i get a Erreur 324 (net::ERR_EMPTY_RESPONSE)

  7. Chasal
    Member
    Posted 2 years ago #

    Hi,

    I am getting the same errors, it's literally driving me crazy.

    WordPress do not provide any tool to really debug and find out wether this comes from a plugin, a theme, a setting, or the server end.

    Can anyone say wether he find out a way to get ride of this ?

    Thanks a lot.

  8. Pothi
    Member
    Posted 2 years ago #

    @Chasal

    This could happen, when there are a large number of posts in the site. The purging plugin for Varnish, if you use one, may send too many purging requests immediately after publishing the post.

    To overcome this issue, try to disable that purging plugin and see, if the same issue occurs. If disabling that plugin solves the issue, try contacting the author of the plugin to see, if s/he can fix the issue.

    Hope this helps!

  9. Krishna
    Volunteer Moderator
    Posted 2 years ago #

    Thème blognews with 19 widgets

    Does one really need all these plugins?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags